djay 2 on ipod touch 4g

I own an ipod touch 4g. I’ve been told that djay2 should work on that device. However, I can’t install the app in the app store since djay2 requires now IOS7 which is only possible to install on ipod touch 5g devices. Is my ipod touch 4g already too old for djay2?

Searching the web I’ve found pages where djay2 was also announced for ipod touch 4g - this was around september 2013. did you lock out those devices in the meantime?

Thanks for your support.


We had to remove iOS 6 support for one of the recent updates. iOS 6 will be re-added soon.

djay 2 for iPhone is supported on iOS 6 (again).

Not sure what you mean. Please simply open the App Store app on your iPhone and download djay from your Purchases list.

Hmm. Can you please make a video recording showing the problem so we can see exactly what is going on?

You can e.g. upload it to Dropbox and share the public link.

Thanks for the vid. Which iOS version do you have exactly? Also, what’s the model number of your iPod? You can find the model number at the back of your iPod.

Just tried installing djay 2 on a 64GB iPod touch (4th gen) with iOS 6.1.6 and experienced no problems at all.

Have you tried restarting your iPod touch? Can you install other apps that require iOS 6?

Glad to hear you figured it out! :slight_smile:

Any news on this? I used to be able to use djay on my ipod touch, but since the upgrade to djay 2 I can’t. I’m also using iOS 6 which is the most recent update.

The version that is saved in the icloud doesn’t work with iOS 6. How do I access the version that will? I still get the same error message that I need to have iOS 7.

Thank you!

That is what I am trying to do. If I try to download from Purchases list, I get the following error message “You must update to iOS 7.0 in order to download and use this application.”

How can I upload the video?…

iOS 6.1.6

model# MC544LL/A

That didn’t work, but I “Reset All Settings” and was able to download it. Thank you for all your help. I love this app and am very happy to be able to use it again.

I tried all of this and it did not work for me. Is ios6 support removed from latest update?

Never mind on the previous post. Got it sorted. Great app!