Djay 3.8.8 Crashes when accessing Midi Devices

Since upgrading to djay 3.8.8, every time I try to access the Settings-> Midi Device-> MIDI DEVICE-> “my midi controller”, it completely crashes. I have tried 4 different midi controllers, 3 different USB cables and with or without a powered USB hub. I had no issues before the latest release. Clearly this is not midi controller, cable or hub related.

I’m using an iPad Air 4th Gen, iOS 15.4 and have more that 160GB of free space. I have not installed any new apps recently. I’ve also tried a hard reboot of the iPad.

Since I use heavily customized midi mappings, the app is really not useable at the moment with the default built-in mappings. I’m about to do an iPad backup restore to the previous djay version, but I thought I would post here first in case there is a quick fix.



I found a temporary workaround about an hour ago. Set VoiceOver and navigate to the MIDI settings and apply your custom from there. It will only work for the time you have djay running. Once you relaunch the app, it will crash again. VoiceOver is very tricky to use. All I know is to single tap to select an icon on screen and double tap to confirm it.

1 Like

I’m having similar immediate crashing problem since upgrading to djay v3.8.8 on iPad 6th Gen running iOS 15.4 with a Pioneer WeGO4 as MIDI controller.

Problem: going to djay settings > MIDI Devices > DDJ-WeGO4 causes immediate complete crash of djay.

Fortunately, the MIDI profile still works and I can control djay with my WeGO4 controller. I just can’t edit the MIDI profile or access it at all.

@CliffyPop that is actually the exact same problem I am experiencing. The default MIDI mappings still function, but for me they are not really usable because my current workflow relies heavily on my custom mappings.

@DJ_Norm thanks for the suggestion. I decided to do an iPad recovery to before djay 3.8.8 until Algoriddim releases a fix. Thankfully, I remembered to do a backup before upgrading from 3.8.7.

Version 3.8.9 was released already on Friday with a fix for this issue. Our apologies for this mishap!


Thanks for the update Anders. @DJ_Norm and @CliffyPop have you guys tested v3.8.9? Did it solve the issue for you? I did a full iPad backup recovery to djay 3.8.7 so I’m a bit hesitant to try the upgrade since everything is running fine on this version. Thanks!

Yes, it works normally now. Safe to update

1 Like

@Slak_Jaw All seems fine for me too after update.

1 Like

Great! Thanks for the info @DJ_Norm and @CliffyPop

Same here, no issues so far with the latest update, besides not getting various requests that we asked for…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.