djay not loading current iTunes Library

Strange. djay only shows an iTunes library from a couple weeks ago. It was fine alst night but opened today and not current! Tried to refresh in djay. No luck. Rebooted twice, no change! How can I get djay to recognize current library?

Hi Dan,

Did you receive my email? Did the steps help? Reposting it here, in case someone else encounters the same issue:

Please try the following:

  • open the “Disk Utility” app
  • select “Macintosh HD” from the left tab
  • run “Repair Disk Permissions”
  • wait until it’s finished
  • start djay again and select “Analyze” from the “Library” menu
  • when asked, click on “OK” and do not browse to any folders (Note: djay automatically detects which folder it needs permission for)

By the way, the issue that djay loads an old library is actually a problem with iTunes (or the songs in your iTunes library). When you have songs in your library, that have “invalid” characters (e.g. Japanese or other special characters), then iTunes will fail to update the “iTunes Library.xml” file. In this case, all apps that rely on this file (e.g. djay and even iPhoto) will only be able to load the library as it was when the xml file was last updated.

in itunes preferences, make sure that in the “advanced” tab, the box is checked for “share itunes XML file with other application”. this immediately solved the problem for me.

Just Had The Same problem, I eventually found out that It was because the 1Tb external drive that my iTunes library Is stored on was Full, just 417Kb left, I removed a few large files & Hey Presto! Problem Solved, I Hope this helps