DJay Pro 2 some songs don't sync

I have notice on a few songs Sync does not work in Djay Pro 2
Sync works well with these songs in DJ Pro
but some how they don’t work in DJay Pro 2

Any ideas?

Sync is erratically available and/or unavailable during Automix and regular operation of djay Pro 2. Just updated to djay Pro 2.0.3 and the sync issue still exists.

Never experienced this issue with any revisions of djay Pro 1.

I just upgraded my MacOS to High Sierra 10.13.2, and so far I have not experienced the intermittent sync issues that I was having when I was on 10.12.6. I’m going to keep testing djay Pro 2.0.3 on the new operating system and will report back if any new information is discovered.

I would appreciate if you went into setting up the sync in a little more detail… Do you have to do this with every track before playing ? Just bought this yesterday and having drifting issues… Thanks beforehand…

Hi guys,

can you give us an example of tracks (Spotify would be great) which are not syncing, or even share an exemplary video with us.

Cheers,Lukas E.

I can’t get any to sync at all. Is this a April fools joke early or something? Seriously? $49 and the songs don’t sync when you press sync?? What the hell is going on with this company?

I agree I had a heap of problems with sync across all genres but adjusting the beat grid will fix all sync problems it’s time consuming to start with but the end results justify the means

Not every song needs to be adjusted however if the first downbeat is not on the first beat grid you will need to do this manually usually 30% if the time you will need to do this and it also depends on the genre. Many 4/4 beats are ok but with urban and even pop it may not work all the time but beatmixing manually is part of the learning curve of being a good DJ

It seems the problem is coming from iTunes playlist. If you drag and drop the same affected songs from your “Finder” onto DJay Pro2 Deck
Sync will work as it should.

Hopefully this issue will eventually gets fix.


Faced this sync issue too, with 1 song only, from Spotify.

Didnt try to load the song by dragging.

I had the same issue. It happens when the bpm of the incoming track is faster or slower than the currently playing track by a percentage greater than the deck’s selected bpm control percentage.

It’s easy to fix. In settings, just change the tempo adjustment range (for all decks) to 50% or 75% before you press auto-mix.

It’s confusing because manually pressing sync matches bpm without regard to the deck’s bpm adjustment percentage.

Hope this helps. Cheers.

You need to use the Zoom feature and then adjust the grid via the Downbeat —> Set Grid Start and/or the Grid —> Shift tools.

I can go into further detail if it’d help. It’s a pretty straightforward and quick process once you get the hang of it.

Hope this helps.


Sync is not working correct for 90% of my songs Spotify and iTunes. The beat lines are not lining up all the way and it sounds awful.

Auto loop isn’t working either. Starting or stopping just before the beat line.

Others are having this problem and we need a solution. These are key features and we paid good money for djpro 2 and Spotify.

Thanks for the response.

I’m still relatively new to this so further detail would definitely help.

The problem in having is the cue function isn’t starting where I’m setting the cue on a track that begins on the off beat, so I move the cue curser; press play, and is still in sync with the offbeat.