Djay Pro AI and Djay Pro 2 exiting skipping loop when triggering mixer transition using keyboard

On both Djay Pro AI and Djay Pro 2 I am experiencing an issue where if music is currently playing on track A and I have a loop set but not playing on track B and I press → or ← to transition from one track to another, the software will sometimes completely skip over the loop that i’ve set.

This seems to happen at random or at least I haven’t been able to consistently recreate it myself but I have been able to record video of it happening. This is extremely problematic since a random skip of a loop i’ve set up with completely botch a transition. This is happening on the most recent versions of both Djay Pro 2 and Djay Pro AI.

For some reason the “Create a new Topic” interface isn’t allowing me to upload my mp4 recording so if you’d like the recording I may need an email to send it to.

Hi @djDork,

Thanks for posting this on our Community. Let’s get to the bottom of this.

First of all, could you please tell us what djay versions (number) your are using and what macOS version you’re running?

Also, could you please tell us what Automix settings you have selected in the djay settings? To open the settings press and ,

Furthermore, so that I can better assist you, could you please record a video capturing the explained issue and attach it to your reply? Please use one of the following methods for sharing your video:

  1. Upload your video file to a cloud storage service, like Google Drive, Dropbox, or OneDrive, and share a link to your video.
  2. Upload your video file directly to our Dropbox service using this direct link: Upload to Dropbox.

Please put your username in the filename so we can easily track this.

Cheers, G

I’m using MacOS 11.1 Big Sur and DJay Pro AI 3.1.7 and DJay Pro 2 2.2.8.

My Automix settings are:
Mix:
Transition: Fade
Duration: Manual 8 bars
Tempo Adjust: Morph

Song Range:
Start Point: Automatic
End Point: Automatic
Use start and end point of song if available: Checked
Maximum Song Play Duration: Unchecked

I’ve uploaded the video using your Dropbox service. Thanks!