Djay Pro crashing on iPhone / Wego4

I am running Djay Pro on an iPhone XR with a Pioneer Wego4 controller which has worked perfectly until recently.

Now the app crashes constantly, loading a new track, pressing sync, pressing play anything really. Sometimes after a few seconds sometimes a few minutes but it’s basically unusable now.

I used to use Spotify (gutted I can’t anymore :face_with_symbols_over_mouth:) now have to use Tidal, which I don’t like as much at all but it should at least work!

I have tried restarting the iPhone, deleted and reinstalled the app and other obvious steps but can’t get the app to work longer than 5mins without crashing.

HELP!

Are you on iOS 14.2? Apparently, there’s a nasty bug that will only be resolved with iOS 14.3, as per this thread: djay app randomly crashes on iPadOS 14

1 Like

Ok thanks for the heads up!

In the meantime, you can use the iPhone version of WeDJ. This is what I’m using with my iPad Air 2 and WeGO4 as an alternative to carry on mixing until djay 3 is fixed, as WeDJ doesn’t crash on iPadOS 14.2 when used with a controller (the crash only seems to occur when using djay 3 with a controller on iPadOS 14.2, based on my own testing).

The iPhone version of WeDJ is free and supports SoundCloud Go+, so fits my use-case. The iPad version is not free, doesn’t support SoundCloud and hasn’t been updated as recently as the iPhone version. WeDJ was designed to be used with the WeGO4 as well, so has native support for the controller, which I discovered when I connected it to the iPad for the first time.

At least there’s a way to stay in the mix for now.

Hi,

This does sound like the iOS 14.2 coreMIDI crash issue people have been seeing. Good news is that, fingers crossed, it looks like the current iOS 14.3 developer beta 3 fixes it, according to feedback we’ve seen from users testing.

I am downloading 14.3 beta 2 as we speak on my iPad to see if it fixes the issues. I have a Reloop Mixon 4 that I am having the same issues with. Crashes within minutes of opening the app and trying to do anything. I will report back if it works. Anyone can sign up for the Beta Software program through Apple. Usually pretty bug free unless it’s a major iOS update (going from 13 to 14 for example)

I can confirm that iOS 14.3 beta 2 did fix the issues I was having.