Djay Pro crashing on selecting cue device (Win11)

For some reason, this doesn’t happen on my desktop installation, just my laptop- but here we are.

I’m trying to use my laptop speakers and a headset recognized as only a pair of headphones to practice some mixes on-the-go (and to perform, since obviously I’m not bringing an entire desktop PC to a gig). However, when I launch Djay Pro, it’ll launch okay and operate perfectly normal until I select a device to cue to (in this case, my headphones) and hit Apply, which immediately crashes the application.

Occasionally, it’ll launch, then recognize the computer speakers as a “new audio device”, and then crash in the same manner (which seems like the app trying to cue to the laptop speakers, then applying it, doing functionally the same thing).

Does anyone else have this issue? How can I go about fixing it? The issue still persists after a Windows “repair” and then a “reset” of the app. I haven’t gone as far as uninstalling.

Here are links to crash logs of the first example and the second. I hope this is informative- and I hope to get back up and running on my laptop as soon as possible!

Hi @BSSDRVN,

Thanks for reporting your experience when using djay PRO on Windows 11. And thank you very much for already providing the crash logs. I’ve shared these with our developers and they’ll look into that as soon as possible. I’ll keep you updated here with any news from them. We kindly ask for your patience.

Please note we are continuing to test djay PRO on Windows 11 ourselves. In theory, djay should continue to work as intended on the new Windows update. Did you previously run djay PRO on Windows 10 on the same computer?

Also, could you please tell us whether you are connecting any audio or MIDI devices to your computer?

Thank you for your cooperation.

Cheers, G

Hi! Thanks for your quick response, I understand development is difficult and responding to bugs is somehow even harder. I hope this can help you.

I did, for a little bit, and it worked smoothly- but when I was running it on Win10, I didn’t have a controller connected, just my headphones and a mouse to practice on.

In the situation described, I only had one controller (the DJ2GO2 from Numark) connected, as well as my headphones into the laptop’s combo jack. (Come to think of it, I don’t actually think the controller was connected when these crashes happened, but the same result occurs when I have the DJ2GO2 connected as opposed to not.)

I appreciate your continued work.

BSSDRVN