Djay Pro Demo Win10: Vestax Spin 2 / Casio XW-J1 cueing not working

My Vestax Spin 2 (Casio XW-J1 in Windows) works fine but i can’t use cueing (pre-listen) and activate it from buttons. In “Audio Device Settings” in can only view “Speakers (XW-J1 Audio)”
With other similar applications cueing is good.

Is it a demo limitation or a bug to fix?

Help me, i’m considering purchasing the application but this issue causes me some hesitation

Lenovo Yoga 2 13" i3 4Mb ram
Windows 10 Version 1607 for x64-based Systems (KB4015217)
Casio driver data driver 04/04/2013

Giovanni are you getting full stereo from both decks in this config. I too tried this 2 weeks ago and the issue I had was that the right deck wouldn’t play through the mains in full stereo. I will follow your solution step by step though when I return home next week. Thanks for the info. Cheers


Here are the steps to be taken

  1. Connect audio card (controller) and set on
  2. Type “Control Panel” in the search box on the task bar (Search Windows field) and then click on CONTROL PANEL icon
  3. Click on “Sound” icon
  4. On “playback” tab, you should find “Speakers: XW-J1 Audio”
  5. Select it and click on “configure” in the bottom left
  6. On the monitor display will appear “Choose your configuration”: in the “audio channels” menu select “Quadraphonic”
  7. Click next: in “select full-range speakers” flag both the settings “Front left and right” and “Surround speakers”
  8. Click “next” again and then click “Finish”

Now in Djay Pro settings you will see “Master Volume” and “Pre-cueing” slider with their respective controls and pre-cueing buttons will light on controller

CRITICAL POINT: if you don’t see “pre-cueing controls” click on “Configure audio device” and uncheck “Exclusive mode”