Djay Pro Jump to Endpoint vs Jump to Automix Endpoint

I’m currently in the process of updating from Djay Pro for Mac to Djay Pro 2 for Mac. Most of this update has been smooth and uneventful. However, there is one piece of functionality that I already miss from Djay Pro, and that is the jump to endpoint function normally bound to the “t” and “y” keys. In Djay Pro this feature jumped to the end of any song automatically. However, in Djay Pro 2 this key is called “jump to automix endpoint” and in practice seems to act like just another queue point. Hitting “t” or “y”, or triggering the event those keys are bound to by default, does not jump to the end of a track but instead plays from the beginning of that track.

Is this behavior intended? And either way, would the team consider changing this behavior either by adding a new “jump to endpoint” control or fixing the existing one to mimic earlier Djay Pro behavior?

Thank you for your time and attention!

Hey Andrew,

From my experience if the cue points are not set, the song will jump to the beginning.

Are your white/gray end cue points still there?

Maybe try to delete one then resetting it to test.
I just tested both versions, they’re fine on my end.

Yeah, my local Spotify tracks that downloaded via Spotify music downloader also occur the same error. But I tried LaidbackFred’s suggestions and everything is fine.

I met the same problem. It happens when I mix the local Spotify files (which is downloaded by the Spotify downloader Mac). Waiting for a solution.