Djay2 doesnt remember IAPs after update

since the most recent update (RED) of Djay2 on iOS i have to restore my FX IAP purchases every time I start Djay. Its quite annoying, especially if i forgot to restore and end up with only the standard FX while I’m in a mix already. Can you pls look into this?

Djay2 on IPad Air with iOS 8.1

This reply was created from a merged topic originally titled Bought FX disabled over and over.

Today at work i needed a little break so i thought i’d play around with djay2. I have bought all the FX packs but when i tried to use them they were all locked (as when before i bought them). This is the first time i have noticed this, ie they have worked before.
When i got home to my wifi network i restored purchase and i got the FX back. I shut the app down and opened it again … disabled! After a few attempts i stopped as the fire built up in my chest.
I gave in and “bought” the free red skin since i figured that my problems started with this red thing. It didn’t help, only made my screen red which i later found how to restore to the more eye pleasing gray.

How do i restore them once and for all? I deleted the app and synced with itunes … didn’t help, same as above.

Bonus question - im not interested in samples, can i turn off the new splash screen? I feel that if i bought the software and ALL the FX packs, maybe i should be left alone and be allowed to use it as intended…? Just a thought!

I can’t restore purchases at all.

Mine works again, as well. Thanks so much!

Hi Everyone,

This is a known issue and our developers are already working on it. We apologize for the inconvenience.

In the meantime, I’m afraid you need to restore your purchases every time you restart the app.

If restoring doesn’t work for you, please reach out to support(at) so we can troubleshoot the issue together.

We’ve released an update with a fix for this issue. Please download djay 2.7.1 in the App Store and let us know if you need any further help.

In my case restoring purchases is not possible, even…

Everything fine now, thank you for excellent service!

Hi Warren

Thanks, works now for me. I’m still getting the RED update splashscreen everytime i start DJAY2, is that a bug or a feature? :wink:

BTW, any indication when the next bigger feature update is about to hit? Its a good app already, but the inconsistent BPM analyzing drives me nuts. And the BPM cant be set manually, which makes it even worse. And a camelot system for the keys is way overdue as well… :wink:

But thanks again for the quick fix, one less annoyance :wink: