Djay2 not connecting to my DDJ WeGo2.

My Algoriddim djay2 isn’t connecting to my DDJ WeGO2 like it used to. The large red “Pioneer logo” doesn’t scroll across either. Recently updated my iPad mini to the latest ios 7 update.

just turning on the app after my wego2 is on. haven’t played on it for a while, but don’t think I’m forgetting any steps here. can anyone help?

Hi Eugene,

Do you have the latest firmware for your WeGo2?…

Hi John,

Sorry to hear that.

As an experiment, please try the following:

  • plug in your WeGo 2
  • open the Settings app and go to General > About

Is there an entry saying “PIONEER DDJ-WEGO 2”? Try this on both your iPad and iPhone.

Hello. I have just received my ddjwego2 back from decks after sending it back due to it not connecting. They told me that it worked fine on their machines but I have again tried it with my updated iPad mini and iPhone 5s with no joy.

They have updated the firmware on the unit.

Please can anyone help this is extremely frustrating.

no their is not