Do iCloud private addresses mess with the djay/Tidal auth handshake?

NOTE: Please use the search function above before posting to avoid creating duplicate topics.

  • Device model (e.g. 2020 iPad Air 4th Gen): iMac 21.5" Late 2013
  • Version of operating system (e.g. macOS 14.4.1): macOS Catalina 10.15.7
  • Version of djay (e.g. 5.1.2): 5.1.5
  • Hardware/controllers used (e.g. Reloop Mixon 8 Pro): none

Your question:
Had to update iCloud stuff (credit card and password) and now it seems I can’t get djay to recognize my Tidal subscription with the DJ add-on…djay keeps referring me back to the Tidal subscription site, where I find that djay is not listed under Third-party apps…should it be? what am I not doing/not doing correctly? can anybody walk me through how to get djay on that list if it needs to be? Is this the right place for this; should I be asking the Tidal support?

I don’t seem to have the search skills to be able to determine if anybody else has run into this issue before, and what the work-around is…assuming djay stilll can run under this OS on this host machine…

Help djay community/mods - you’re my only hope!

Have you tried logging out of your Apple id on your iPad and then logging back in?
I had a similar issue and that did the trick for me.

1 Like

Mac, not Pad. iMac.
It’s clearly an authorization issue.

You will still have Apple ID. Try logging out and back in of your Apple ID.

1 Like

Hi @heysoundude,

  1. Please log out of TIDAL from within the djay app.
  2. Close djay.
  3. Log out of TIDAL on all browsers and stand alone TIDAL apps.
  4. Log out of your Apple ID on your iMac.
  5. Reboot your iMac.
  6. Log back into your Apple ID.
  7. Launch djay and log back into TIDAL within djay.

I’ll try this again (I believe I’ve already tried this…perhaps not in this particular order…which in my mind shouldnt make any difference, but if it does, I’ll come back to let everybody know)

UPDATE - In the words of a favourite fictional character, This Is The Way.
In my case, I had to disable the TIDAL app from autolaunching on boot, and then it all went smashingly well. @Slak_Jaw 's reply has been marked as the solution

That’s great news. Thanks for the follow up @heysoundude