Double-djay on Mixon 8

Device model 2024 iPad Air + 2024 iPad Air
Version of Djay 5.1.2
Hardware/controllers used Reloop Mixon 8 Pro

Setting up a back-to-back rig on the Mixon 8 and for various reasons we’re wanting to use two separate iPads each running Djay (connected via Ableton Sync).

The problem is that in 2-channel mode Djay is expecting the Mixon to control decks 1 and 2. The Mixon, however, is configured to control either channels 3 and 1 (left side) or channels 2 and 4 (right side). So basically, this configuration seems impossible, which is both unfortunate (as it’s really cool for back-to-backing) and rather unexpected (as the Mixon is mentioned as having among the best support for Djay and seems uniquely enabled to support this config given it has the 4 mix channels and 2 USB devices).

Anyone had any luck making it work? Is there any way of modding the Mixon mapping to make this happen?


1 Like

I’ve tried that on Rane One and couldn’t get it to work either,

I’ve been working on having two separate mappings for the two iPads - one whose decks 1 & 2 are controlled by Mixon channels 3 & 1 (which basically correspond to USB channels 2 and 0, as well as a few other even channels), and the other controlled by Mixon channels 2 & 4 (basically USB channels 1 and 3 as well as a few other odd channels). It works well, except for one thing: Djay seems to mute any of its two decks whose channel is not assigned to that USB device.

I guess it’s the Djay software which is doing the muting since I have it set to Internal mixer mode so I suppose the Mixon would only see the two decks pre-mixed. I’m a little confused as to how the Djay software would know which Mixon channels are mapped to which USB device. I wonder if this is part of the MIDI mapping and if I’d be able to correct it… are there any Algoriddim staff around who could help? Or is there any proper reference documentation anywhere for all supported MIDI codes?

Hi @wasabidj, I think the only way to make this work the way you want is to customize the MIDI mappings for each iPad. You’ll basically need to change the Deck assignments for every control. A fair bit work, but it should work. I recommend that you test it out with a few controls first before attempting the full customization.

Hi Slak_Jaw - thanks for taking the time to reply.

This is exactly what I did (see my previous post). However, it seems that the Mixon is somehow muting the decks on Djay which do not share the same index as the channels assigned to that Djay instance. So I’m very interested to understand what MIDI command this “silent mute” or “remove channel from the mix” might be, and how I could stop it from being sent.

You’re welcome. Hmmm… I’m not sure. I know that the Mixon 8 supports External Mixer mode. Maybe worth testing that out to see if you have more success.

I tried that yeah, but it doesn’t seem to help: the Mixon still manages to mute the channels somehow. I guess there’s probably a MIDI instruction being sent behind the scenes which mutes channels right before they get mixed. But without any docs it’s pretty hard to understand how this could be mapped away.

maybe use a midi monitor? such an app can show what midi messages happened in a list, unlike the midi learning tool that only shows the last that occered. with this list you can look the individual midi messages in the learning tool to find any mute action.

Hi @wasabidj, I spoke with the engineering team. The Mixon 8 is an internal mixer mode device and djay sends the audio for the Main and Pre-Cue output to it (not for every individual mixer channel). So when you flip a mixer channel to another source, djay is responsible for not sending that channel to the Mixon since a mixer should only play the selected source for each channel. Currently, the channels are hard coded as 3-1-2-4, so these cannot be user customized. However, the engineering team is investigating to see if it’s possible to make these customizable in the future.

I see.

For what it’s worth, it seems like someone else also asked for this to be made possible here: Viewing decks 3 and 4 in 2-deck mode (pro/classic) - #12 by Myalteredsoul

Perhaps a low-effort solution would be to just enable the possibility of mixing all channels’ outputs, overriding anything else(?)

1 Like

Hi @Slak_Jaw - is there any news on this investigation or any way I can track this issue? Thanks!

Hi @wasabidj, I just sent a follow up to engineering. I’ll let you know when I hear back. Thanks for the reminder!

Hi again @wasabidj, I spoke with engineering and this will be addressed in 5.2.1.

Great news! Many thanks @Slak_Jaw and the team!

You’re welcome @wasabidj