DVS and Sync Issues

hi
i am new to Djay. coming over from Traktor.
really like to automatic beatgriding and Synch Feature at DJAy. I am just testing the DVS Feature… with Traktor Vinyl didn’t worked, but with rekordbox vinyl…
now to my Issue. when DVS is in the settings inactive… the Synch between tracks is perfect…
when I activate DVS - the Synch is not working anymore… I understand with vinyl beat adjust by myself, its how I learned. but also in intern mode, the synch is not working anymore…
anyone the same issues?

thanks

1 Like

Hi,
i have noticed the same issue.
@Algoriddim is there any chance to fix it?
thanks

Hi @Alexanderexpander,

Thanks for posting to the community for the first time!

Please note that djay supports standard time code DVS systems that use a control tone of 1kHz (which the vast majority of DVS systems nowadays do).

Could you please record a video capturing this sync issue and attach it to this thread? If the video is too big (i.e., over 50MB), please upload your video file to a cloud storage service, like Google Drive, Dropbox, or OneDrive, or to your own YouTube account, and share a link to your video.

Having a clear view of the issue will go a long way towards investigating and finding a solution!

hi.
finaly i made a video, too show my synch issues… here is a you tube link…Djay DVS Synch issues - YouTube

Hi @NathanielAlgo I’m experiencing the same sync issue when using DVS any chance of a fix ?

1 Like

As far as the problem mentoned in the first post with iinternal mode while DVS activated is concerned, I can’t reproduce that. Are you sure you have chosen the Beat Sync option in the preferences?
As far as relative mode is concerned, perfect sync with DVS is impossible due to imperfections of analog signals, which are influenced by wow and flutter of your turntable, dirt in the pitch fader, the quality of the pressing of your time code, the quality as well as wear and tear of your stylus, dust, cables, interference, etc. etc.
On top of that, when you press sync and match BPMs, it will almost always be different internally than on the turntable, so the software has to translate that, which adds another layer of complication.
Besides Djay, I use Traktor regularly, Serato occasionally and DJ player pro every once in a while, and all of them show a similar behaviour. One workaround is to activate sync again while the record is playing (you’ll have to have Beat Sync activated for that), but it will eventually drift slightly out of sync again.
A turntable is not a midi controller. It delivers an audio signal which can not be perfectly stable due to it’s analog nature and system-inherent behaviour of turntables. If you want perfect sync, you’ll have to ditch the turntables and use a midi controller.

hi @jimbobatzke Thanks for the Tip with checkin the beat synch option. snd its activated.
still the same issues, that in dvs mode there is now synch to beat grids. not even with the Update 4.07 Today.
i am aware that we worked with a turntable and this signal is imperfect. and this I love on working with turntables… I working since almost 17 ears with Traktor. there I can use their timecode and synch works perfectly.
i play often old disco records. these are never tight. I like to move over to djay, because their Beat grid analysis is super, even with elastic beat grids. for thise records I need to have a synch button and this is synch option is not working with dvs right now…

and I would be just happy if the INT Mode in dvs, would behave a the normal mode inactive dvs mode…

1 Like

Alexanderexpander:
I have just tried it again, and for me, two old RnB/Disco-ish tracks sync as perfectly as they could. The trick is to re-press the sync button as soon as the tracks are running. Here is how I do it, maybe you can reproduce it when you know what’s different for me than for you.

I tried it with Djay on iOS (15.6.x), hooked up to my Traktor Audio 10, 2 turntables and a Numark DJ2Go2 Touch for some extra buttons.
I used the tracks “Kashif - I just gotta have you” and “B.B.&Q. Band - Imagination”. When these are just beatmatched, they will run out of sync immediately, because their speed varies quite significantly. With Sync enabled, they just sync.

I used the following settings:
DVS in relative mode
Settings->General->Sync Mode->Sync Type: BPM and Beats
Settings->General->Sync Mode->Turn off on pause, scratch or cue jump->disabled

Then play one track, cue up the second one and play it. Djay will disable the Sync function at that point. So just press the Sync button again to reengage, and voila, they stay in sync.

The fact that sync mode disables when you stop the record or cue the vinyl somewhat makes sense, because if you would force perfect sync when you do that, you would basically force the software to do something completely different than what the record does, making vinyl control useless. However, Djay seems to be able to cope with very light taps to slow down or speed up the record. This helps for the parts in songs with speed so irregular that Beat Sync can’t keep up.

So if anything, disabling the function “Turn off on pause, scratch or cue jump” does not do what the average user is expecting. Basically, it still turns off sync on scratch. I would expect it to be able to cope with syncing even if the downbeats are manually adjusted away fron another quite a bit, but the software seems to need them very close to another to work. If Algoriddim could improve on that, it would be much appreciated, but in principle, DVS/Beat Sync does work, at least for me.

hi @jimbobatzke
omg! Thank you very much! I disable the function “Turn off on pause, scratch or cue jump” and everything work like I expect it.
DVS is perfect now. synch works…
and now Djay will be my Software of Choice…
thank you Jimbobatzke for this tip. you made my day…

1 Like