Echo Effect Issues

Hello

I’ve been using a ddj 400 with djay pro for 2 years now and it always be great, unfortunately since the new updates, I think until the 4.0.5 to be exact, i’ve noticed that the echo effect as an annoying depth issue, it last way too long. Also the echo effect has no more depth settings. I thought with the 4.0.7 the issue will be fixed but not at all.
I’m running the 4.0,7 version with on a MacBook Pro 15 Retina half 2014 on Mac OS big sur 11.6

Cordially

1 Like

I have just noticed this in the last few days as well, I mainly use the Echo and Dub Echo and the depth/time setting is different to before…

2 Likes

Yeah true right ? before it used to be great, don’t know why they changed it

1 Like

So if someone fells on this post and is searching how to resolve it,
i finally found some kind of a solution and at the same time understood the problematic
With a shorter beat the depth is shorter, and more you go in longer beats more the depth is long
In the previous versions the depth doesn’t change with the beat, now in the new ones looks like there’s a predifine setting or algorithm which linked the depth with the number of beats. Unfortunately with long beats like 2/4/8 etc the depth is really too long
To figure the issue i try to stay or to comeback 1 at the max beat and don’t move the knob lower than that

Yes that’s exactly what I found, I don’t set it past 1 and even then sometimes it’s not the best…

1 Like