'eject' song loaded in player

Hi there, does anyone know how to simple ‘eject’ a song that is loaded into one of the players? Some kind of eject button in the software would be a great option…

On iOS, long press on the cover of the song which brings up a menu that contains eject :blush: I don’t have access to other systems right now but I guess it could be a right-click on macOS.

Pressing that trackpad on my Macbook till my finger numbs…no result :upside_down_face:

On Mac, open the Help menu and type „Eject“ into the search field.

it’s there…in the pull down menu under the deck in the menubar but that’s quite a hassle. Especially when in full screen mode :face_with_raised_eyebrow:

I don’t use me trackpad when I’m mixing.

Cool, and you eject the track how exactly then?

I actually use Serato on my Mac without the trackpad. I have algoriddim on my iPad. I occasionally spin on the iPad but mostly on my Mac.

You can also use the keyboard shortcut setting to set up an Eject shortcut directly on your keyboard.

You can find the keyboard settings as tab of the djay settings.

Perfect…that was the answer I was looking for. Thanks

On DJay AI for Mac the eject no longer works for me since the last update. Dragging and dropping a different track works but then the original plays after the dropped one has played. It seams to me the current AI version is very buggy.

The AI on Mac desktop is the first version I tried after using Serato and Rekordbox. Found a few issues that could use some tweeking but don’t know if they worked in prior versions. The preferences section is not as big as in the other mentioned programms. However I think there is a lot of potential. Neural mix, matching, video functions, playing Tidal video, etc. did the trick for me to try DJayPro. Hope future updates will even upgrade functionallity…

We are sorry to hear that. Could you tell us which exact version you are using and which eject you used? Did you eject via the Top Menu Bar > Deck 1/2 > Eject?

I am on MacOs 11.4 (both intel & M1 have the same issues. and DJay Pro AI V3.1.2. I was using he menus eject.

The following is reproducible on my systems:

  1. in view select auto mix
  2. select a playlist and move a few of those tracks ( say 10 or so) into the automix queue ensuring source is Manual
  3. Click “Mix Now”
  4. Replace the up next with a different track from the auto mix queue
  5. Drag and drop a different track to up next or use the skip button
  6. Select “Mix now”
  7. Repeat steps 5-6 several times
  8. After a few changes random tracks will start appearing in up next from the playlist, but that are not in the auto mix section
  9. At some point the same track will keep coming up in up next.
  10. switch the view to classic
  11. use eject on the inactive table until the auto mix queue is empty, then click again on eject. The last track will go back onto the desk

Sometimes in classic mode the eject will simply not work. only option is to restart the program.

Sometimes the volume of a track being played will unexpectedly reduce in volume.

In automix view, sometimes deck 1 is in the menus sometimes deck 2, but in either case hitting eject clears the active track and playback aborts.