Enlarged Waveform not displayed on the CDJ-3000.

I played with CDJ-3000 two days ago, but enlarged waveform was not displayed on screen of CDJ-3000.
I’m not sure if it’s djay PRO AI for Mac(v4.1.1) issue or latest CDJ-3000 firmware(v2.03) issue, but I’d like to report it.

1 Like

same here, newest macOS and 4.1.1 update.
After update on 4.0.0 waveform lost.

1 Like

In my case I had a problem using Pioneer DJ CDJ-3000 and Denon DJ X1850.

I think it doesnt matter in what combniation.
I try setup like: Denon X1850 prime + CDJ 2000 Nexus
Denon X1850 prime + CDJ 2000 Nexus2
Pioneer DJ DJM-900NXS2 + Pioneer DJ CDJ-3000
There was no waveform on the players anywhere.

Tonight, I have a chance to try out CDJ-2000nxs2 or CDJ-2000nxs + X1850, So I’ll check it out.

Waveform did not displayed even with CDJ-2000nxs2 + X1850.

1 Like

After update on 4.1.3 still not displayed on x1850 + CDJ 2000 Nexus.

But the weird thing is that I saw the waveform during randomly one song out of about a hundred, but when I try it again with same song, the waveform didn’t load again.
CDJ 3000 + DJM 900 nxs2

Second time I play with X1850 + 2000nxs2
And I have same experience. During the party one random track show the waveform, but if I try load it again, waveform just dont be displayed.

1 Like

I also saw the waveform only first one time on CDJ-3000+X1850.
However, it never appeared after that.

I played with lost waveform follows:
CDJ-3000 + X1850 two time (4.1.1)
CDJ-2000nxs2 + X1850 one time (4.1.3)

I remember, it has showed up waveforms on CDJ-2000nxs2 + DJM-900nxs2 when using djay Pro AI 4.0.12.

Hi @Akifumi_Konishi @DjRocky,

Sorry to hear that you all have been running into this issue as of late.

Would either one of you be able to send us a video of this issue in real time so that our dev team can take a further look at it for continued review?

Looking forward to hearing back from you. Have a great day!

I sent you a video by message because I playing copyrighted music.

Hi @Akifumi_Konishi,

Thank you so much for sharing that video with me. I’ve gone ahead and shared this with the rest of our tests for further review and will reach back out as soon as I hear about an update.

Additionally, could everyone that this experiencing this or a similar issue make sure to update djay to the latest version (v4.1.3) as well as ensure that you’re controller has the latest firmware installed on your device so that we can accurately troubleshoot this issue with all of you?

Have a nice day!

I tried environment follows:

macOS Ventura 13.0.1 (latest)
djay PRO AI 4.1.3 (latest)
CDJ-3000 Firmware 2.03 (latest)
CDJ-2000nxs2 Firmware 1.85 (latest)

I saw problem with these.

1 Like



Lol, if I record track with djaypro, CDJ3000 actually can show the waveform :see_no_evil:

Hi everyone,

I’m happy to announce that this bug has been fixed in the next update for djay Pro AI.

Please make sure to download the update as it rolls out in the Mac App Store.

Have a nice day!

3 Likes