Fader / Knob Pickup not working

Hi all, I’m running the latest version (at the moment it is V5.0.3) of Djay Pro on a M1 Macbook Air.
As the title suggests, whether I select the pickup tick-box or not the result is the same.
The volume immediately jumps to the position of the hardware fader / knob instead of waiting until the hardware reaches the same software position. I have tested this with 3 different midi controllers just to make sure it’s not a device specific problem and the result has been the same.
So just to make sure everyone understands my issue, I’ll describe the setup & what happens.
I am using bass, mid & treble eq knobs for those specific frequencies, I am using the same 3 knobs with “shift” pressed to control bass, harmony & vocal stems. That in itself works beautifully, however if I adjust one of the stems (holding shift), then try adjust the same knob for eq, the software will instantly jump to the position the knob is at as soon as I touch it. I have tried enabling the pick-up option under the advanced midi mapping section, yet it has absolutely no effect. The software still suddenly jumps to the hardware position, no matter whether the pickup option is enabled or not. I am really hoping that I’m just doing something incorrectly. If anyone can offer some assistance, I would really appreciate it.

Hi @magrepairs,

  1. Make sure you add Pickup Mode to the MIDI command for each of the 3 EQ mappings and for each of the 3 Neural Mix EQ mappings.

If I understood correctly, You are trying to use the Eq and Neural mix Eq at the same time?
If so then it can’t be done…
If you have say the Bass set at 1 O’clock position and then adjust the Bass dial whilst holding Shift + Bass to enable Drums Neural Mix, The Bass will automatically revert to the 12 O’clock position

Hey Slak,
Is he asking the same question I asked a few weeks back?

@magrepairs also you might be able to simply your mapping by removing the SHIFT+ and simply mapping an available button to Toggle Neural Mix - EQ.

This will basically toggle back and forth between the EQ knobs controlling regular EQs and Neural Mix EQs.

Yes, I am using one knob to adjust the bass, then the same knob with shift held down to adjust vocals. This works perfectly when moving from the centre position of all (eg bass & vocal & knob). However if I try adjust any one of them thereafter, the software knob instantly jumps to where the hardware knobs position actually is, meaning there is no soft-take over (or pickup as it’s called in Djay).

Oh wow! That seems like a much simpler solution. So just to make sure I understand properly, do I map the eq knobs only once (to eq), but then when I switch to neural eq, the knobs will adjust that instead & have no effect on the normal eq & vice versa?


@magrepairs you just leave your regular EQs mapped as normal and remove the SHIFT+ commands that you added for Neural Mix EQs. Map a button to the toggle and you can just switch back and forth.

Make sure you still have the Pickup Mode ON for each of the EQ mappings though.

1 Like

Thats great news. I’ll map it like that instead, much easier as well.
Thanks so much for your help. You rock!!

You’re welcome @magrepairs. Happy to help.


Only one problem I’ve found with the approach offered by @Slak_Jaw, if you map a button to alternate between normal EQ and NM EQ using the same set of encoders, the software will, without fail, reset the EQ of the one not shown in the GUI.

Let’s say you have upped the High, lowered the Mid and the Low EQs. Press the toggle to switch to NMEQ and instantly the standard EQ resets everything to the midpoint. This also makes the track that you’d ‘tuned’ with the standard EQ instantly sound like it’s coming from a bean tin……

I have this toggle set in my controller so I can use it, as it is handy, but be warned that toggling to one will reset the other….


1 Like

Thanks for your input. I actually noticed this today. Which means we are basically back to square one. It’s doing almost exactly the same thing. I guess the big question then is… what is the solution to this “issue” (can we call it that?). Is there no way of adjusting normal & neural mix eq’s independently?

1 Like

Thanks for the info @sooteee and @magrepairs. Sorry that didn’t work. It might be something specific to EQ mappings. I’m travelling at the moment so I can’t confirm this myself with my hardware. I have forwarded this to the engineering team for further investigation though. I’ll report back here with any news. Thanks.

1 Like

I thought it might be a bug / oversight that the two EQs aren’t interoperable, seems odd.

Anyway, bugger off…. You’re on holiday!!


1 Like

Hahaaa! Okay, about to lose WiFi anyway :stuck_out_tongue_closed_eyes:

1 Like

Yes I worked that one out as well, It would be good if this could be fixed in future updates…

1 Like

I have found a workaround but you can’t use the EQ / NM EQ switch button or else it all resets.

The way around it is to use the NM EQ setting in the gui (and your controller if used) and to then control the standard EQ from the individual decks settings on the right of the 5 options.

As long as you don’t use the toggle switch you can now use both EQs together.



No matter what I try, I get the same result. A quick test confirms that this is definitely a bug. I turned on pickup mode on my bass, mid & high eq’s, made sure they are all in the middle on the software. Unplugged the controller, turn all 3 knobs completely down, then plug controller back in. At the slightest touch of any of them, the software instantly jumps to that position. The point of having a pickup / soft takeover is to prevent drastic changes when a hardware fader or knob position is different to the software position. Right now, this doesn’t work (except on the pitch faders).

Hello everyone,

I’ve just returned from vacation and wanted to follow up on this. The engineering team has told me that Pickup Mode is currently not supported for the EQ / Neural EQ controls. They are looking into this further to see if it can be supported. I’ll report back here when I have more news. Thanks.

1 Like


I think they’re wrong…

I use pick-up mode on my NM crossfader mapping.

The midi command is in the ‘Advanced’ section….

Unless I’ve misread the thread, pick-up mode exists for the faders and EQs…