Got the Reloop BUDDY for Christmas 🎄 and it doesn’t work?

I was in tears of joy when I received the Reloop Buddy. But sad to say it doesn’t work.

My gear:

  • iPad Pro M1 (iOS 16.3)
  • Anker 8-in-1 hub
  • Bluetooth mouse & keyboard :keyboard: :computer_mouse:
  • Scarlett 2i2 (with phantom power mic)
  • 23” LG monitor :desktop_computer:
  • non-functional Reloop Buddy

My Issues:

  1. LED pads don’t seem to have no light.
  2. Controller connected in settings but no sound coming out of any of the Reloop BUDDY audio ports.
  3. No way to contact Reloop support & couldn’t find any information online anywhere to help!

Hoping I don’t have to return what I thought was an awesome :star_struck: Christmas gift :gift_heart:

Did you try to connect it without the Scarlett? Did you try a dedicated power supply? The switch is on iOS?


Did you try (re-)connecting the buddy after djay has started? My hardware often misbehaves if I first connect it and then start djay but it always works the other way around.


Are you using a Powered USB hub or is the Reloop Buddy connected directly to your camera adapter?


First of all, you should connect the controller to the iPad alone, without any other devices. If that doesn’t help, try a different USB hub or a different USB cable. And then we will see.


As others have suggested, simplify your setup first so you can narrow down and properly troubleshoot the problem.

  1. Connect the Reloop Buddy directly to the iPad using a USB-C to A cable and connecting to the USB-A port on the Buddy labelled iOS.
  2. Make sure the switch on the side of the Buddy is moved to the iOS position.
  3. If this doesn’t work, try a different USB cable.
  4. If that doesn’t work, I suggest connecting the Buddy to a PC or Mac via a USB-A to B cable to see it it works there. Make sure you move the side switch to PC mode. If this doesn’t work, then it’s likely a problem with the Buddy.

In you picture it appears that you have the Scarlett connected to the Buddy in the USB-B port. Please note, that when using a USB-B cable the switch on the side must be in the PC position. When using a USB-A cable the switch on the side must be in the iOS position.


Yes, I tried all the options in guide plus other variations MacBook Pro, iPad Pro and iPhone 12Max nothing worked. I can get sound and some features but no lights just a very dim [MODE] button unfortunately.

Yes I did that as well, thanks for trying.

I tried with everything receiving independent power supplies and yes I use the Anker powered hub.

I did it directly connected to the iPad Pro initially. When I inboxed I first followed all the suggestions from guidelines before trying any other options. And still no LED lights.

This is what I see even when it’s on play tracks and scratches no lights.

I guess it’s defective?

Because I can’t see any colors or light I have no way of getting into my flow cause I have to rely on the screen to know what’s happening it’s like I don’t have a controller.

My Hercules works perfectly fine but has the obvious limitations.

Well if you tried all of that, then it seems like your Reloop unit is probably defective.


Edit - looking at YT videos it appears that the mode buttons are indeed on by default. When these are on you can’t select a track and load it with the controller?


Looking at this picture it appears you are using the wrong port. You shouldn’t be using the generic USB B port.

Can you try it again with your original iPhone / iPad cable and the USB A port?

1 Like

I tried with my iPad Pro and Apple cable and purple cable from box and still NO luck. It lights up on power up and then off. It plays and controls some functions but No RGB lights or colors.

Unfortunately I can’t upload video. But maybe I can make a YouTube video to show you all what happens.

Edit - Did you try the correct USB port with the right switch setting? That’s key.

1 Like

Thanks for all the trouble shooting tips I tried all the suggestions as well as following guides with Reloop and Apple cables and still no luck with RGB pads. The pads work for some settings blindly, but no colors/no lights… I am putting in for a replacement this week.

I got the replacement and it a success!!

Thank you :pray:t4: to everyone who helped and guided me on this journey. I appreciate you all.


3 posts were split to a new topic: Reloop Buddy not working with djay for Android