HD library not loading fully

I have 30,000+ tracks on my HD library but it will only show the first 1050. The others are there but blank when viewed as icons or list and will not load to decks. I can find them in a search, but I want to be able to see them all.
I’ve tried uninstalling and reinstalling; I’ve tried deleting the information about where the library is stored; I’ve tried deleting the database. None of these work.
What can I do to get it to recognise my library?

Hi Keith,

Thank you for getting in touch.

We are sorry to hear that. 

If you search for a non displayed track, are you able to load and play them?

In which file format are the tracks which are displayed in djay and in which file format are the tracks which are not displayed?

I would assume you have Apple Music tracks, either not purchased or not downloaded in your library.

You assume wrongly. I wouldn’t touch Apple Music with a very long barge pole. I have mp3s from Amazon or ripped myself from CDs I own.

All the tracks I can see are mp3 format. So are those I can’t see. The system reaches a point in the alphebetic artist list (part way thrpugh A-) then stops.