Hercules Inpulse 300 freezes after 5 minutes on Mac Mini

I’m using a Hercules Impulse 300 controller with DJay Pro on the latest Mac Mini. All of my software for everything is the latest version. The Impulse 300 keeps freezing up after about 5 minutes of use. Unplugging it and plugging it back into the Mac Mini works for another 5 minutes and then it freezes again. Help, please.

Hi @Tony_Magbanua, to help troubleshoot this, please provide the specifics of your setup (not just “latest”) as this may be necessary for us to replicate your specific issue:

Device Model (ex. 2020 iPad Air 4th Gen):
Version of operating system (ex. iOS 17.3.1):
Version of djay (ex. 5.1.3):
Hardware/controllers used (ex. Reloop Ready): are you using the MK1 or MK2 version of the Impulse 300?

In addition to the above:

  1. Have you downloaded and installed the latest macOS driver from the Hercules website? https://support.hercules.com/en/product/djcontrolinpulse300mk2-en/
  2. Have you tried using a different USB cable? Please note that not all USB cables are the same. Some only work for charging and cannot transmit data. Ideally you want to use the cable that shipped with your hardware or a high quality replacement with dual ferrites on either end.
  3. Have you tried connecting the USB cable to a different socket on your Mac?
  4. Is the djay application still running normally when the Impulse 300 freezes up?
  5. Does the music stop?
  6. Do the buttons on the controller remain illuminated or does it lose power?
  7. Are you running any other applications in the background on your Mac (ex. iCloud backup, background App updates, etc.)?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.