Hercules Rmx Controller Won't Map

I have a Hercules RMX and I cannot get the jog wheels, volume, pitch, or any other knob on the controller to map, any other button in the configure window works.

That is my current configuration, everything on the controller works except the crossfader, both jog wheels, my pitch bend and volume sliders. Also my treble, bass, and medium knobs, however the kill button does work.

Yes I have, I’ve tried setting up the midi on my own and used the built in option neither works.

The device works with other software, unfortunately I am forced to use other softwares due to no resolution.

Hi Daniel Snyder,

thank you for your post.
The Hercules RMX is natively supported by djay Pro, all you need to do is accepting the midi mapping dialog window.

Cheers,Lukas E.

Hi Daniel Snyder,

have you tried checking the natively supported mapping (click at “Midi Configuration” and select “Hercules DJ Console RMX Built-In”)?

Cheers,Lukas E.

Hello Daniel Snyder,
On my side all Rmx controls work in Djay Pro Mac.
Can you check in another DJ software if your Rmx actually works?


In DJay Pro, can you
1 - go to MIDI > Configure DJ Console Rmx Port 1…
2 - Click on Show Advanced Control Options
3 - And check, for each control which are not effective in Djay Pro, if the control type is properly assigned in the MIDI Configuration:

  • For the jog wheels, it should be Rotary (01h/7Fh)
  • For all the faders and rotary buttons (except headphones and mic volume), it should be Fader / Knob.