How to make a playlist play to the end (With Automix) and then just stop without going back the start?

How do I make a playlist play to the end of all the songs in it using Automix and then have it so it just stops without going back the start of the playlists again?
I’m sure the old version functioned like this if you just pressed “Stop Automix” mid Automix (It would continue the playlist until it ended).
Now if you press “Stop Automix” that just means that no more songs play AFTER the current song your on finishes.

Hey @coffee_king,

Thanks for asking.

You can set Automix to repeat or shuffle a playlist by tapping on the options button here:

Let me know if you have any other questions.

Cheers, G

1 Like

That is nothing like the question I asked you.

I’m not sure I understood your question then… Would you like the Automix Queue to keep automatically playing when you press on Stop Automix? You say this use to work on the old version of djay. However, I just checked on djay PRO for iOS (legacy-app) and it does not work like you described above. Stopping Automix stops the automatic transitions and the automatic song loading.

Cheers, G

Hmm, I could have sworn the old version worked how I advised otherwise I don’t know why I’d be complaining that the new version doesnt function in the same way. Maybe I am wrong then.
Anyway, what I want is to be able to do is to start a playlist and have it play all the way through to the end (Without me having to watch over it) and then just stop. WITHOUT it starting/looping the same playlist over from the beginning again.
Or to then move onto ANOTHER playlist once the current playlist has ended.

Hi Coffee_king

I was interested in this issue so I tested it out. Guillermo was correct in the functionality but you are correct that there should be an option in settings for Repeat and if not enabled it should stop at the end of the playlist.

I went back and tested Djay 2 and this works just the same as Djay Ai. Ie. It permanently loops around the playlist until you stop a track or turn off Automix. Interestingly enough, if you look at the Automix list you will see that as each new track is loaded to a deck it gets added back to the bottom of the Automix list, that’s why it never ends. (I called it Automix list so as to not confuse it with the “queue”).

The only work around at the moment (sloppy), is to clear the “queue”, add your playlist to the queue then Automix the queue. This will then play all the tracks and stop at the end.

Hope this helps

Ps. If you use the workaround method you can achieve the other functionality you wanted, which was going on to play another playlist after the first finished. You can add more than one playlist to the queue. Hopefully the Automix will be enhanced shortly to include more features.

I appreciate your thoughts. As you say though very sloppy.

Wasnt there a feature to remove the song from the playlist once played ?

Sussed it… if you use auto mix and add a Playlist, then it does what you say, it adds the songs back to the bottom of the list. But if you don’t select a playlist and instead, do Add Song, then you can select a playlist and click select all. This will play all the songs and after each song It will remove the songs providing you have selected remove songs played in the library section. Once it gets through all the songs, it stops.

Where is “Add Song” once you have the Automix window open?
I appreciate your input but this all sounds very convoluted doesn’t it.

Click on the circle that has 3 lines. The attached screen will come up. Select Add Songs. Then a new screen will appear, find the songs you want to play, if you want everyone, do select all but alternatively, select just a few.

I appreciate the effort but this “Add Songs” option isn’t in the OTHER AutoMix that uses the actual decks (The one below the orange AutoMix option) (To the left is REC and to the right is Settings)

It is on mine, this is what I get when I select the orange button between record and settings.

Maybe it’s because I have the taken up the option for the annual subscription. So I have the pro version.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.