I need a HOW TO help. Just got a SX2

When I hit my CUE but on the mixer of the SX2, IT GETS LOUD (How to prevent that)

Cross fader assign… I like for my crossfader to fade as going to left or right but I have to crossover for it to actually change instead of fading HOW TO fix this

When I turn the jog wheel back while playing it only slows down instead of stopping and letting me rewind back

To me seems like the sync isn’t as flawless as without the controller unless I’m lookin too much into it

Hi there,

When you say hit Cue, which Cue are you referring to? The big silver one above the Play button (one per deck) or the small red cue buttons (1 per channel)?

Also, when you say it gets loud are you referring to the volume from the mixer to your speakers or the volume in your headphones?

For you crossfader to fade across you need to set the default crossfader to either Default or Linear in Djay settings>mixer>crossfader curve. You then need to set the crossfader curve dial at the front right of the controller to also mirror this behaviour, I find setting it so it’s about the 2 to 3 ‘O Clock position works fine for an old style ‘fade across’ function.

I don’t have my SX2 out at the moment but if you have a play with various combinations of the Play/Slip button being on or off and also press the shift button before pressing Play/Slip, it has different effects on the platter.

One final note, when you say turn the jog wheel back are you using the outer ring or the flat plate?

Many people make the mistake of thinking that the big jog wheel is just that, but in fact the outer ring and top plate are different and depending which bit you are touching can have different effects on the track, I.e. slow down / speed up / forward / reverse / stop. So make sure you’re touching the right part of the wheel for the outcome you want.

Let me know which Cue buttons your having issues with and I’ll try and sort it out for you.

Cheers

:+1:t3:

Hey. Thanks for the help. It’s the red cue button and makes it loud coming out the speakers and headphones. I’m using the flat plate
Should I be on internal or external mixer

I’ll have the controller out and set up tomorrow (Sunday), will have a look and get back to you then. :+1:t3:

This controller is supported in internal mixer mode. Let us know if the issues persist.

As @Guillermo said, internal mixer in settings.

I’ve had a mess around with mine in various combinations and I cannot get the volume to change when pressing the cue button?

Let me know if you’re still having the same problem and we’ll go from there.

No longer having cue problems but still having crossfader problem.
THE CROSSFADER STILL WONT FADE. JUMP ONCE I CROSS THE MIDDLE



Your crossfader assign buttons on picture 1 is showing that crossfader isn’t used at all i.e. that each channel is in the “THRU” position bypassing physical crossfader.

You need to individually set to each channel to A or B.

1 Like

After the picture I put
channel 4 on THRU for mic
Channel 1 on A for Left
Channel 2&3 on B
Still the same issue

Hi @Slim89,

Thanks to @sooteee and @dj_romy_fi for helping. :pray: The crossfader assignment is obviously very important.

This is due to your crossfader curve setting. Please make sure that you have the crossfader curve knob is not all the way to the right. You’ll find this knob on the frontal side of your controller.

Captura de pantalla 2021-10-12 a las 14.02.54

I’m sure this will finally solve your problem.

Cheers, G

1 Like

As I said in my original post, I have the crossfader knob (as pictured above) set to around 2 or 3 o-clock, works perfectly.

If you have that knob turned all the way to the right it’ll be in ‘cut’ mode and will not fade as you wish.

FIXED THIS ISSUE

I DID A RESET ON THE CONTROLLER works fine now…Thanks for the help guys

1 Like

Glad it’s all fixed for you fella!

Enjoy it!

:grinning: