Icloud tunes still showing with hide tracks in the cloud tuned on

Icloud tunes still showing with hide tracks in the cloud tuned on, using iphone 5.

Sorry to hear about this issue. Does this happen in all tabs (Playlists/Artists/Albums/…) or only in specific ones?

Thanks for the additional info. Which version of iOS are you using?

Thanks. Are all tracks not downloaded from iTunes Match showing, or only some?

Please make sure that “Hide Tracks in the Cloud” is enabled in djay (not in the Settings app). Tap the gear icon and select “Library”.

Hi James,

Are the songs also showing up in the “Songs” tab or just in the playlists?

Can you load the songs or are they greyed out? Also, please upload a screenshot of the Library settings in djay.

Thanks for the screenshots. The only place where songs would be really hidden is in the “Songs” tab. Can you please upload screenshots of the “Songs” category as well?

Yes, that’s correct. As far as I know, playlists are only hidden if and only if all songs in the playlist are hidden.

Good idea for the workaround.

I have the same problem. It is happening in all tabs. I use djay 2 on my Iphone and Ipads (2 and mini) and they all have the same problem

I am on the same versions. 6.1.4 iPhone 5, 6.1.3 iPad 2 and iPad mini.

It seems like all of them.


iOS 6.1.4 on Iphone 5
iOS 6.1.3 on ipad 2
iOS 6.1.3 ipad mini

all 3 same errors, screenshot attached missing tracks are greyed out.

any news on this? super annoying. thanks.

Just started having this problem on iPad 3. Was never an issue before. Have enabled the in-app setting multiple times.

The change to the situation is this: I’m using smart playlists in iTunes. Previously I was organizing by basic playlists iTunes. Is the hide feature not compatible with smart playlists?

Hi, Warren. Good question. All songs appearing in Playlists, Songs, Albums, Genres, despite Hide being enabled (in-app and in Settings).

Warren: Thanks, and, yes, confirming that they are greyed out — the cloud-located songs that are still showing, despite setting the Library option to Hide tracks in the cloud. Uploading image in a second, as a reply to this topic.


Photo 1 of 2: Library settings iPad 3.

— James


Photo 2 of 2, showing a Playlist with cloud songs showing, greyed out.

— James

Cloud tracks are hidden in the Songs tab. And, I think you’ve answered a key question, here. One can’t hide cloud songs in the Playlist view, is what I think you’re suggesting. I wish that we could! Adding that functionality to the list of suggestions for the next update.

Meanwhile, a workaround to the no-hide in Playlist limitation is to analyze the tracks in Playlist, then sort by BPM. The playable tracks are then grouped at the top or bottom of the list, since the greyed-out Playlist tracks don’t get assigned a BPM.

Thanks for the help, Warren. Have a good rest of your week.