IDJPRO firmware don't update !!!!

Hello, i try many times to click on update IDJPro firmware…but nothing…
I make a test and my idjpro is still in mono!!! toooooooooohhhhhhhh
Help me, please :frowning:

Simon from Numark here :slight_smile: Sorry to hear your having an issue can you confirm if you have tried power cycling both the unit and the iPad? Can you confirm that no other apps are open at the time?

I updated straight away when the update went live… Now I’m having problems with the touch platters not responding…HELP!? I have a Friday night party coming up!

What iPad generation does everyone have?

uninstalling and reinstalling from the app store is a sure bet.

Can you post an iPad ‘snap shot’ (lock + home simultaneously will drop the picture in your “photos”)

Showing the following menu:
Settings > General > About > iDJ Pro


So you are saying the other iPad failed to update as well?

You will want to contact us as we may need to check out your hardware. Sorry for the troubles.

Germany looks to be your closest office:
Tel: +49 2154-81299-20

You should get the following message after pressing the “Update” button;

I ran this on an iPad 3 and it went through without issue…I know that doesn’t help you guys with the problem, but it does show that the process works - albeit perhaps for some.

Please contact Numark customer support if you are still experiencing this issue after following the steps above.

Hi Bigfred,

Which iPad do you have? Which iOS version is installed on it?

Hi Erik,

Please kindly explain the issue further so we can assist you better.


Go to iPad’s Settings -> General -> About -> iDJ Pro. Please upload a screenshot of this window.

Hi Bigfred,

Can you please upload a screenshot or a video recording showing the whole update process? Thanks, that would be very helpful!

If you are having difficulty updating with the latest version of djay for iPad app and firmware for your iDJ Pro, please perform the following:

  1. Make sure you have an active internet connection for your iPad.
  2. Using the App Store app, ensure that you have the latest version of djay for iPad installed on your iPad.
  3. Reconnect your iPad to the iDJ Pro, and try running the app again:
  4. Remove the iPad from your iDJ Pro.
  5. Quit all apps on your iPad. To view a video walkthrough on how to quit apps, click here.
  6. Power-down your iDJ Pro.
  7. Then dock your iPad, and connect it to the iDJ Pro.
  8. Power on the iDJ Pro.
  9. Launch djay for iPad.
  10. When the iDJ Pro Firmware Update Available message appears, press Update.

If the message persists after trying the suggestions above, please contact the Numark technical support team for assistance:


When you call or email, please provide your current iDJ Pro firmware version, and the hardware serial number from the bottom of your unit. For a walkthrough video on viewing the currently installed firmware version, click here.

David, sorry for the late reply.

Looks like you have the same problem as the people here. Please try the suggestion in my official reply above and if that doesn’t help, then I’m afraid you need to send in your controller to Numark support.

I try to delete and install Djay but the problem persist !!! My IDJPro is from July…

Hi warren,
Ipad3 with ios 6.0.1 and djay 1.6.3

Idjpro product version 1.0.0
Idjpro program version 1.0.3

Hello, is there some news about this problem ???