Impossible to calculate the BPM and data lost after upgrade

Hello, I’ve Djay 2, for some of the songs in my iPad it’s no possible to obtain the analysis of BPM, I’ve tried to erase and reload these songs but the result is the same, I cannot save a new BPM, furthermore, after the last upgrade, 2 weeks ago, all BPM analysis and cue points are deleted, two times in different moments, I have been obliged to re-analyze entire library, It takes a lot of time, is not funny … Please help me to find solutions … Thanks

Hi Angela,

Sorry to hear that. Please kindly explain the problem a bit more:

  • Does the analyzed BPM show up in the library after you loaded the song?
  • What happens after you try to edit the BPM?
  • Do you have iOS 7?
  • Did you re-sync your songs to your iPad?

It sounds like an issue related to the file itself. How many of your songs are affected? Can you please email us at Thanks!

Hi Angela,

Thanks for the files and we’ve been able to identify the problem. Our developers are already on to it!

Thanks for your reply, i’ll try to explain better this problem:

  • the program tries to analyze the BPM but cannot fix it, So the waveform remains gray and the result DON’T appears in the library … so every time I load the song is not as immediate as the other songs already in memory and the program needs to recalculate the BPM …

  • If I try to tap a new BPM manually I can enter this new TEMPO but nothing changes compared to above, I cannot fix it …

  • I have already iOS7 and all updates made until now …

  • Sorry, what do you mean for “re-sync” my songs to my iPad???
    I’ve tried to erase these songs and reload them again even under a different name and volume but nothing change …

fortunately not many, a dozen to a thousand … anyway I’ll try to send you a couple of that by Wetranfer because the file is too big for an e-mail (I work with 24bit audio files) … please let me know if you received the file correctly…