Improved MIDI Rotary Encoder Settings (library selection)

Good day,

Device Model: MacBook pro M1
Version of operating system: MacOs 14.4.1
Version of djay: 5.1.5
Hardware/controllers used: Midi fighter twister

When using the midi rotary library selection mapping, it is hard to select a track because of the small encoder steps. Tiny movements cause the selection to move too fast, making it difficult to select and when you think you selected it, it already moves before loading. It is possible to work with, but during a performance when the stress level raises a bit, this is annoying.

Suggestion is to implement it such that if you select 50%, it uses 2 steps, 25% 4, etc, to move to the next track. Or something similar. But in fact, the percentage setting is not good at all for these types of discrete rotary selections, something entirely different would be preferable if possible.

Cheers, Bart.

Hi @Brainbox, When creating new topics, please do not forget to answer the questions in our template with specific details about your setup not just “iPad” or “Latest Version”. This helps all of our community moderators to provide the most effective support to users with the utmost efficiency. Thanks!

Device Model (ex. 2020 iPad Air 4th Gen):
Version of operating system (ex. iOS 17.3.1):
Version of djay (ex. 5.1.3):
Hardware/controllers used (ex. Reloop Ready):

You may also want to experiment with the different rotary Types: in the Advance Control Configuration section of the MIDI Learn Tool. Depending on your hardware, Rotary (01h/7Fh), Rotary (3Fh/41h) or Rotary (Absolute) might work better than the default Fader / Knob type. If after experimenting with these settings, you are still not able to get the control you’re after, please let me know and I’ll forward this onto the dev team. Thanks!

The problem is the amount of steps per revolution. The midi fighter twister has a shift function for setting with increased accuracy, that reduces this, but you have to press the knob for that and if you release it and turn it just a bit the selection is off again. 01h/7Fh is not supported by the controller and Absolute obviously will not work.

Please take my request into account. Thanks.

Thanks for the additional information @Brainbox. Have you tried adjusting the encoder sensitivity using the Midi Fighter Utility?

Yes :slight_smile:

(20 characters)

1 Like

I know on my controller, you can adjust, and have to adjust, the speed down real low under the “advanced options” that’s hidden in a drop-down menu via an arrow, in the mini mapping screen.
You have to see if the control gives you the option to adjust speed, not all of them do., you can try hitting the drop-down menu on control type see if any of those options unlock the speed slider for you

Here’s a picture of the slider I’m talking about

On my DDJ-FLX4 when I hold shift and twist the selection knob I mapped a higher speed to my main selection knob (again under the advanced options in the midi mapping) in order to skip multiple lines at a time cause I have a large music library and try to avoid using the mouse and keyboard when possible.

Anyways, It sounds like you may have tried something like that already, but just in case you haven’t figured I’d post.
Good luck let us know if you figure it out

1 Like

Yeah, thanks :slight_smile:

The midi fighter twister does not support the 01h/7Fh control type, maybe that is the start of the ping-pong communication. The next issue might be that the speed adjust for the 3Fh/41h works differently for the library scroll compared to what I understand 01h/7Fh does for you. The speed only has effect when you select multiples of 100, like 200 or 300%, where it skips tracks. Settings below 100% simply do nothing. It looks like a bug to me, but I also use a weird controller from a DJ perspective, I just started using the twisters because I already have them to use with ableton. It is difficult to generate any interest for the issues with this piece of hardware because of this niche.

Edit: Made text more accurate.

Hi @Brainbox, thanks for the additional information. I’ve shared this all with the engineering team to see if they have any suggestions. I’ll report back when I have news.

Hi @Brainbox,

  1. I discussed this with the engineering team and they were able to implement a fix. It should be addressed in an upcoming djay release.
  2. Also, there’s no functional difference between 01h/7Fh and 3Fh/41h. Both formats accomplish the exact same thing, it’s just that each manufacturer prefers one format over the other (so it’s totally reasonably that the Midi Fighter only has 3Fh/41h and not 01h/7Fh).
1 Like