In ver. 4.0.9, the sound disappears when Software FX of Seventy is turned on.

We suspect that some of these issues are related to your SEVENTY devices using an older firmware version that is not the current version, which doesn’t support software FX.

Please update your firmware to the latest version by getting the latest “Seventy Control Panel/Driver” from the RANE downloads page. Launching that should show you the option to update the firmware.

The current Version of the A-TRAK Edition is and there is no new firmware distributed on the Rane website.
Sorry if you are talking about SEVENTY and not including A-TRAK Edition.

Hi @Anders,
There is no firmware update option with latest driver file for MAC users (1.0.2) available at the Rane website… :weary:
(PS: Software FX works fine with Serato with this version)

4.0.10 is out !

@Anders: Still same issue for me… :frowning:

@nicefinga @alproducer could you please try it ?

Will do as a SOON as I get back.

No difference in this area. Same issue on the Rane Seventy original version… so not sure what support was added to it.

Please once more reset the audio device settings in djay to defaults with 4.0.10 and let us know if that changes anything.

1 Like

Ok I will try it asap :wink:

@Anders I did a reset with no changes…

Ayeee…! 4.0.10 it Works!!



You can enjoy fx with your mixer now, I can’t even activate it on mine :sweat_smile::sweat_smile::sweat_smile:

I suspect they have the a-track edition at algoriddim :joy:

@Anders any idea for regular rane 70 users?


That is very likely😅

But this time I found a problem that the key does not change when the pitch is changed, so I created another topic!:fearful:

1 Like

Hi @DJTonyBlanck, sorry to hear this is still not working for you.

At this point this is likely caused by the older firmware version your mixer is using, as we developed the integration against the newer firmware. We have reached out to RANE to try to clarify how you can update your firmware or possibly get access to the older firmware, and I would encourage you to also reach out to them in order to ask how to update your firmware. I’ll let you know once we have any updates.

Hi @Anders,
Thx for the update.
I will open a case at Rane.

Hopefully we get this going!

Hello Anders,
I have just received a answer from Rane support:

The RANE Seventy does not have a firmware listed on the downloads page we have added below so unfortunately, we believe this to be an issue with Algoriddim DJ directly.

I did a manual mapping while waiting, it’s usable for fx but sub menus for pitch play are missing. :frowning:


Hi @Anders
Thx for new 4.0.13 version !
I can now access to rane 70 sub menus :heart_eyes:.
Software FX is still not working like A-Trak edition but I will manage this with midi mapping.

1 Like

Great to hear @DJTonyBlanck! Thanks for letting us know that our fixes worked.

That being said we know that is not the latest firmware for the SEVENTY. Unfortunately Rane has not made an updater available on their website, but hopefully you can still receive it from their support.

GREAT NEWS! Will have to try out!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.