In ver. 4.0.9, the sound disappears when Software FX of Seventy is turned on.

In Rane Seventy A-Trak Signature Edition, after updating to version 4.0.9, when Software FX is turned on, it seems that it is not routed to the master mix and no sound comes out.
The indicators for each channel are responding, so I can confirm that the sound is coming to the channel.
This happens when Software FX is turned on in the mixer.
When Software FX is turned on by directly controlling the LCD on the iPad, the effected sound is output as usual.

Hi @nicefinga, thanks for your post.

Can you please try the following:

  1. Connect the RANE SEVENTY
  2. Open Audio Device Setup in the djay settings
  3. Tap “Reset to Defaults”

Please let me know if that fixes your issue.

Thanks for the reply.
I tried it immediately but nothing changed.
I still have no sound coming from the main output.

Best regards.

Hi @nicefinga
How do u enter into software fax mode ?
I tried click on the button, shift+click, double click… but nothing…
Same question for pitch play mode…
Thx.
Tony.
PS: Classic RANE 70, not A-Trak one.

Okay…I’m talking about up to Ver. 4.0.7…
It would be easier to understand if you first change to the screen where you can manually select fx in djay.
Then press the Software fx button in the center of Seventy.
It might be hard to understand, so I took a video.
Up to Ver. 4.0.7, this took Software fx, but with Ver. 4.0.9, you can see that there is no sound coming out of the master as shown in the video.

Pitch Play is very easy with Ver. 4.0.9.
After specifying the Cue point, press the Cue button twice to enter the sub mode, and Pitch Play is automatically enabled.
I have added this at the end of the video as well.

Lastly…I took this in a hurry before I left for work, so don’t mind the sounds of life behind me😅

Wow! thank you very much @nicefinga !
None of these features work for me… :frowning:

Software fx button remains blue and double click on cue button doesn’t change anything.

@Anders I use a classic RANE 70 in 1.0.0.113 firmware version and 4.09 Djay version.

@nicefinga regarding the no sound issue, did you try to change RANE software fx settings within the mixer ?
Try to change usb insert parameter from auto to on.

Tony.

What in the world is going on?
If the buttons don’t change color, does that mean that the connection to the iPad or iPhone is not working?

Thanks for the advice.
I tried it, but the sound before the effect was applied also stopped coming out of the master, so I guess the routing to the master is still wrong… :sweat:

I learned something from this… thanks DJTonyBlanck. Turning on fx within the software wasn’t effecting the track in external mode with my Rane 70 (regular). It was playing the track, but without the software effect. With your advice to turn USB insert parameter to on from auto… BINGO… works!

Also, just like you, my Rane 70 flex / software fx mode button stays blue and unable to go into Software FX mode. The double clicking of the hot cue selector button with a cue point stored doesn’t do anything. So pitch play a no go for me as well.

On 4.0.9 on M2 MacBook Pro.

1 Like

Hi @alproducer and welcome!
Thanks for your confirmation.

@Anders It seems that it’s a bug for regular Rane 70… :frowning:

1 Like

We suspect that some of these issues are related to your SEVENTY devices using an older firmware version that is not the current version 1.1.0.127, which doesn’t support software FX.

Please update your firmware to the latest version by getting the latest “Seventy Control Panel/Driver” from the RANE downloads page. Launching that should show you the option to update the firmware.

The current Version of the A-TRAK Edition is 1.0.0.129 and there is no new firmware distributed on the Rane website.
Sorry if you are talking about SEVENTY and not including A-TRAK Edition.

Hi @Anders,
There is no firmware update option with latest driver file for MAC users (1.0.2) available at the Rane website… :weary:
Tony.
(PS: Software FX works fine with Serato with this version)