In ver. 4.0.9, the sound disappears when Software FX of Seventy is turned on.

Thanks,dude!!

That is very likely😅

But this time I found a problem that the key does not change when the pitch is changed, so I created another topic!:fearful:

1 Like

Hi @DJTonyBlanck, sorry to hear this is still not working for you.

At this point this is likely caused by the older firmware version 1.0.0.113 your mixer is using, as we developed the integration against the newer 1.1.0.127 firmware. We have reached out to RANE to try to clarify how you can update your firmware or possibly get access to the older firmware, and I would encourage you to also reach out to them in order to ask how to update your firmware. I’ll let you know once we have any updates.

Hi @Anders,
Thx for the update.
I will open a case at Rane.

Hopefully we get this going!

Hello Anders,
I have just received a answer from Rane support:

The RANE Seventy does not have a firmware listed on the downloads page we have added below so unfortunately, we believe this to be an issue with Algoriddim DJ directly.

I did a manual mapping while waiting, it’s usable for fx but sub menus for pitch play are missing. :frowning:

Tony.

Hi @Anders
Thx for new 4.0.13 version !
I can now access to rane 70 sub menus :heart_eyes:.
Software FX is still not working like A-Trak edition but I will manage this with midi mapping.
Tony.

1 Like

Great to hear @DJTonyBlanck! Thanks for letting us know that our fixes worked.

That being said we know that 1.0.0.113 is not the latest firmware for the SEVENTY. Unfortunately Rane has not made an updater available on their website, but hopefully you can still receive it from their support.

GREAT NEWS! Will have to try out!