Initializing the Rane ONE controller and switching between sources

Hello,

First of all, I want to admit that djay has quite a lot of potential. But, the Rane ONE controller initialization completely broken. Djay sees that the controller is connected and switches to control from it, but at the same time, the application’s data is not sent to the controller. For example, performance pads glow the same as when the controller is turned on. Also, when connecting the controller on the fly, the position of the potentiometers is not always synchronized with software. If you have this controller - then just connect it to a PC with serato and see how it should work. I think that when switching modes or connecting, the Rane ONE controller sends information about its state, and djay should send its state in response but it doesn’t happen. In the current situation, the application is not suitable for professional use.

Serato Pro MIDI log [Plug on fly]13:29:16.370 To Rane ONE SysEx Serato 26 bytes F0 00 20 7F 01 - Pastebin.com

2 Likes

Which cable/adapter are you using?
It works “just about perfectly” when connected to the Rane One albeit a few little niggling issues that have been noted on here, but I haven’t experienced any of the issues that you have pointed out

I use original cable (Rane ONE) and original usb->type c adapter from apple. I tried another cable and adapter, same thing.

Steps to reproduce (iPad, Djay v4.0.2):

  1. Connect controller to iPad via usb
  2. Start Djay
  3. Turn on controller

or

  1. Turn on controller
  2. Start Djay
  3. Wait until the iPad goes to sleep (the controller will reset its state)
  4. Wake up iPad

or switch source at any time

In the Mac version, it is more difficult to reproduce the problem, sometimes it works sometimes it doesn’t

Steps to reproduce (Mac, Djay v4.0.1) :

  1. Start Djay
  2. Turn on controller
  3. Turn off controller
  4. Turn on controller (sometimes the controller is not initialized)

or

  1. Start Djay
  2. Wait few minets (until the mac goes to sleep)
  3. Wake up mac
  4. Turn off controller
  5. Turn on controller

or

  1. Start Djay
  2. Wait few minets (until the mac goes to sleep)
  3. Turn on controller
  4. Wake up mac

or switch source at any time

In all these cases, the controller is not initialized correctly. Perhaps there are other ways how to reproduce this issue.

I see, Not sure if this is what you a referring but occasionally when I start the iPad and Rane, the Eq and Gain knobs on the Rane may not be at the centre but on the app they are, every other button, dial
or faders don’t exhibit this though…
When this does happen, simply moving the Eq and Gains dials from left to right resets it…
I think this only happens if I shut down the App on the iPad but doesn’t happen if the App is still working in the background…

Slightly off topic but being that you are a Rane One user, since the latest update Version 4, I as well as others on here have been experiencing an issue with using the Search whilst playing…

So the issue is when I have a track playing on deck 1, and I want to search for another track to play on deck 2, I click on the load button, and tap on the search bar, I then type in the track I’m wanting to play next, I then click on it to load but it tries to load it on the deck that is already playing and gives me a warning that the deck is protected…
Luckily I do have Protect Active Deck selected in settings so it doesn’t load…
In order for me to load the track, I need to load any track on deck 2, then I can go through the search function and it will load without issue,
Note this happens whether I’m using Deck 1 or Deck 2…

Could you try this and see if it happens to you as well?

This never happened before the Version 4 update…

1 Like

yes, this is one of the problems associated with controller initialization

I was unable to reproduce the issue on ipad / mac . But in the classic mode in the search dialog, the handle for selecting tracks does not allow you to switch tracks, it selects a track from the current playlist in the background (so you can select the wrong track, but it will be loaded into the selected deck). You can see it in pro mode.

Perhaps you can describe a more precise sequence of actions and on which platform the problem occurs. Maybe there is some setting that forces the track to be loaded into the active deck

I also do not understand the logic of the active deck in djay (depending on the position of the crossfader) when the controller is connected. In classic dj work, the crossfader is always in the middle (except for scratching of course) and the decks that is playing is active and faders control the volume. two are playing, both are active … and it’s strange to move the crossfader back and forth during playback to switch the active deck in the djay interface. Much more logical if a controller is connected and I use the track selector then the active deck should be the one for which I am selecting and this value should not depend on the position of the crossfader. if I just open a playlist without selecting a deck, the field should be empty or set to custom. I’m talking about the “match” interface … but this is offtopic

I use the Pro mode and have my iPad in the Vertical mode.
So basically if l have a track playing in Deck 1, and I’m playing from a Queue list, if l press the Deck 2 Load button and scroll through the tracks that are in queue, l can successfully select the next track that l want to play and it will load on Deck 2,

However if l try to do the same thing, but instead of selecting a track that l have in my Queue playlist and l select the search bar, and search for a track, if l then select the track that l have just searched, it will not load onto Deck 2 instead it will attempt to load on Deck 1 but being that l have Protect Selected Deck activated in settings, it won’t load…

If l wanted to load the track, l have to just select the next track in the queue, then use the search bar to search a track and only then will it load onto Deck 2…
It’s a workaround albeit an annoying one…

So I tried another experiment this time with the iPad in the Horizontal mode and the issue isn’t there…
It works fine

As l said earlier, this issue wasn’t there prior to Version 4 update.

I’m curious to know if any other Rane One or any other controller users using their iPad in Vertical mode are experiencing the same issue,
Private Repress has confirmed it happens to him as well

1 Like

I confirm. I have this problem in vertical mode. Also, the track search window appears on the wrong side. Djay tries to play the track on the deck for which the search box was opened. at the same time, the algorithm for choosing a deck (side) when searching is completely incomprehensible. if I turn the handle on deck 1, the window may appear to the right or left side and vice versa.

Workaround for iPad:

  1. Turn on the controller
  2. Connect to the iPad through an adapter that supports connecting a power source.
  3. Start Djay

Do not turn off the controller and iPad and don’t touch the source switches… If the controller was turned off during DJay operation, repeat the steps. If the iPad fell asleep, then also repeat all over again. If the controller is not turned off and if the iPad continues to work without going into sleep mode, then in general it works.