Inpulse 500 - Deck monitoring dosen't work

  • Device model: Ryzen 7 / 16GB / 500GB
  • Version of operating system: Windows 11
  • Version of djay: djay Pro 5.1.7917.0
  • Hardware/controllers used: Hercules Inpulse 500

Summary of the issue:
The deck monitor (Channel 1-2) doesn’t work. It is midi mapped correct by default. But for some reason they doesn’t work.

How to reproduce the issue:
Just connect a Inpulse 500.

Tried to uninstall / reinstall the ASIO driver without success.
Tried a earlier version of the ASIO without success.
Changed the mapping the Deck monitor to something else, and then re-mapped them. No success.
Tried to yell at the screen, no success.

Authors commentary
Think this problem started with the latest update.
Had no problem with djay Pro 5.1.7887.0


Was able to solve the monitoring problem by going into “Sound Devices” and change Pre-cuing to ch 3-4".

BUT it opened up another problem. Why can I hear the master sound while I have not selected the “Cue Master” button at the MASTER LED.
When I press the MASTER button, the volume gets 100% higher while the sound of the channel I’m monitoring is super low?

Hi @djfredhaze,

  1. Please navigate to djay Settings>Audio Devices and select the Reset to Defaults button at the bottom.
  2. After resetting, please take a screenshot of this page and share it here.


F.Y.I: It didn’t solve the problem

Hi @djfredhaze, thanks for the additional info. It looks like your audio device settings are correct. Please try turning the Headphones Cue/Master Knob all the way to CUE (Left) and test again.


Thanks for fast service.

You can hear the master when you are on 12 o clock on the headphone knob. But when you turn fully either right or left, the sound disappear. But if you turn it to 12 o clock again, the sound is there and kicking.
So sadly the problem remains.

Hi @djfredhaze, you’re welcome.

Please open the MIDI Learn tool in djay, turn the Headphone Cue/Master Knob, expand the Advanced Control area and take a screenshot of the settings. Then share the screenshot here.

@djfredhaze, Thanks for the screenshot. Everything looks normal to me.

  1. Is at least one of your Deck 1 or 2 Channel Faders all the way up when you test the Master Cue?
  2. Also, make sure that your Crossfader is set to the appropriate Deck 1 or 2 side so that the audio signal feeds to the Master Output and therefor the Master Monitor.

If that doesn’t address the issue let’s try the following:

  1. I noticed that the Inpulse 500 has a Master Headphone Monitor button and Channel Headphone Monitor buttons. This is pretty unusual for a DJ controller.
  2. What happens if you leave the Master Headphone Monitor button OFF and select either of the Channel Headphone buttons instead? Do things behave more like expected?
  3. Have you tried this controller with the included DJuced software? Does the Master Monitor work as expected with that software?
  4. I can’t be certain because I don’t have access to this hardware, but it seems like this could be a hardware related issue. Have you tried reaching out to Hercules for support on this? Thanks!
1 Like

Hey mate

Will try it out and get back to you.
But yes, the hercules inpulse 500 works great on both Serato DJ Pro, virtual dj and Djuiced… no offense :).

Back in the day when i had this controller, I never experienced your “headphone” issue.
However i was using it on mac and an ipad, not windows. If I recall well, the deck LED indicator light 1 &2 did not light up (along with a whole host of other LEDs but function-wise it was solid. I wrote several direct emails to algoriddim and i think there was a small adjustment they incorporated a year later

Can you try swapping from internal mixer mode to external?
That could potentially solve your issue.


Out of curiosity, what do you mean above? The LED lights marked 1 &2 for the respective decks don’t light up, right?

If so, I think it was like that for it and many other LEDs on the controller back in Jan 2021 when I first reported to support. If i recall well wht I wrote:

  1. The ring LED on the rotary selector OFF

  2. The 2 big white deck 1/2 activity indicator LEDs OFF

  3. The 4 little white-lit FX buttons OFF

  4. The green lit writings for TEMPO & BEAT ALIGN OFF

  5. THE 8 white/red directional arrows OFF

  6. The white-lit Quantize button OFF

I guess afew of those LEDs were worked and in the mapping later and re working now?
Sorry I sold mine

Thanks for the input @Armigo!

Sorry for the late reply, but life came knocking on the door.

So I did all the troubleshooting with less success but I found a good place to be in the end.
There is something with the Cue/master system that dosen’t work well with Inpulse 500 and djay.
My solution really is to ignore that I have a Master-button.

This is how the sound goes through the Headphones without the master button selected:

This is how the sound goes through the headphones with the master button selected:

So the solution right now is to ignore the master button and everything works still in a satisfactory state.
I’ve been trying to scratch my head with the midi setup but no luck.

Anyway, thanks for all the efforts in this matter to all involved.

Post-Credit-Bonus content:
The tempo sliders are backwards in the default midi mapping with djay.
Easy fix, just letting you guys know :slight_smile:

1 Like

Hi @djfredhaze, thanks for the update. I’m glad we were at least able to sort our a work around. I’ve sent all this information to the engineering team for further review.

Regarding the Tempo Faders, please navigate to the djay Settings>General>TEMPO and adjust the Invert Slider as desired.

Thanks for all the help!

1 Like

You’re welcome @djfredhaze

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.