inter audio export to imovie garageband broken on ipad mini ios 802

ios 802
ipad mini
inter audio broken, cannot export recordings to imovie, garageband
ways to reproduce
open djayapp 2
click red record button
stop recording after 2 minutes by reclicking red record button
access recording
select recording
select open in
select imovies
imovie opens but does not import track.

open garageband
select import int audio app
select dj 2
int audio app cannot be opened

the only way i can use recording from dj2 app is by exporting the recoeding to dropbox
and the use dropbox open with feature to get my recordings into imovie.
previous version of dj2 on ios 7 worked flawles, now its broken on ios8

Hi Kai,

Thanks for contacting us.

(1) Can you load music from other apps into iMovie? By the way, the fact that you can use “Open in” to export your recording in Dropbox actually shows that the feature in djay itself works. djay doesn’t know which app you choose to export the recordings to, the feature works the same for all apps.

(2) I’ve tried this on several iPads with iOS 8. I actually had the same issue a few times, but it seemed to work again after a few tries. Please make sure that you have the latest Garageband and djay 2 updates. Then try restarting your iPad and see if that helps.


We’ve been able to identify the problem with Inter-app audio and djay on iOS 8. Our developers are already working on a solution.

i am using the most current version of dj2 and yes every other try works. Maybe 2 out of 5 times. While dropbox works everytime. Inter app loading of dj2 into garage band does not work at all, with the error message the app is not available, while i can load, via inter app the program Impaktor into garage band with no problem at all. It seems so that some programs can and others don’t. I still believe you should investigate more into the issue from your end.

I have the 2nd issue . I got the latest and greatest version and haven’t been able to record into GB from dJ

I have the 2nd issue and can’t record into GB from DJ despite following the repos. It’s never worked for me since ios8

So what’s the solution?

I’m currently experiencing this issue. No sound at all when using garage band with djay2. This question was asked a year ago, any solutions yet? Thanks.