iOS 17 Public Beta -- OSStatus error -54


I seem to be getting OSStatus error -54 when running on iOS 17 Public Beta. I have isolated the issue to the OS because I just loaded tracks on the iPhone when it was running on iOS 16 (latest production version) and tracks played just fine. I then upgraded the iPhone to iOS 17 and the error came out.

I tried uninstalling and reinstalling djay on the iPhone but same result. I also went to Settings and toggled on and off the setting in djay to Allow Access to Media/Music. Error still persists.

It was only when I encountered the error when I transferred to my iPad, which had been upgraded to iOS 17 Public Beta and tried to load a song that I noticed getting the same error on the iPad as well. Everything was working fine on iOS 16.

Hope this gets resolved soon.



Have the Same Problems. Please solve it.:pray:t4::pray:t4:

1 Like

I have found a temporary fix!
you can play songs from files so store some songs in in the files app and link to the folder rather then picking songs from Apple Music

1 Like

Having same problem. ios 17 beta.

Thank you for your feedback. We have tracked down the issue to a bug in iOS 17 and notified Apple about the issue.


Just updated to iOS public beta 2 today, and the problem is not solved ! Big deception :smiling_face_with_tear:
It seems the error is related to a new file system of iOS.


@Mohamed_Brahim djay does not support beta versions of iOS. If optimal performance of djay is important to you, I recommend you do not use iOS 17, or any beta iOS ever, until official support is announced by Algoriddim.

1 Like

So after the IOS 17 new update today, djay loads music and plays, but no sound comes out.

1 Like

Yes, I can confirm this. Track now loads without an error message but no sound comes out.

And I also observed that all the loaded tracks are tagged at exactly 152.9 BPM.

Same here, no sound on iOS 17 beta. I am hoping this will be fixed before the official release in a few weeks.

Iā€™m just reporting that iOS 17 Beta 4 still has the same issue as above. Track is loading but there are no waveforms and no audio output. And if the track that is loaded does not have a BPM that is already tagged on the track, the BPM is set to 152.9.

Same thing for me. No sound, all tracks at 152.9 BPM. No wave form is displayed.

Updated for about 5 imin today and everything is back working perfectly!

1 Like