iOS Doesn’t show any files on USB devices

I can’t see any files when I plug my USB library in … yet, they’re all there and playable from within the files app. How do I restore access to my USB drive?

Edit: so - if I rename the drive, it ‘sees’ the music, but obviously the play lists can’t see the tracks. Rename the drive back and I have “no music”. So, it’s not the drive itself, or access to it, it’s something in the app that’s preventing the drive from loading up - how can I get the drive to show up again?

Still can’t see the files on the drive … any suggestions appreciated as its months of work lost if I can’t gain access to it.

1 Like

Is there an update on this? I’m unable to use the app …

.

So - with no response other than a quick query asking about OS versions, I thought I’d try anything to get this working. Bought a new external drive, copied all my music to it (768GiB of it - broken into white label albums, each in its own folder - hence relying on playlists to pick a particular category). I plugged it into djay with the intent of building a new playlist. The music appeared briefly, then the drive went offline. It works perfectly in the files app, so it’s not a drive fault.

This app is literally useless … it will only play music physically on the device and, at that point, I have to give up … this, and the dedicated mixer I bought to use it, is dead. Is there any chance someone could check and see what the status of this is? I can’t be the only one with this problem … @Emily @Lukas_E

Dunno what kind of external drive and what kind of cable you are connecting but usually bigger drives needs more power

“There is one big gotcha, which is that many USB flash drives require 500 milliamps (mA) of power, which is more than the iPhone or iPad can provide. When that’s the case, iOS will usually alert you to the problem (or the drive simply won’t show up in Files). You’ll need to provide extra power by plugging a standard Lightning-to-USB cable into the adapter and a power source. That passthrough power should usually be enough to charge the device and run the flash drive, although we’ve seen flash drives that work with the iPhone 11 Pro but not with a 10.5-inch iPad Pro. (Avoid Apple’s older $29 Lightning to USB Camera Adapter, which supports only the slower USB 2 and doesn’t provide passthrough power.)”

So this makes me wonder… when all of your apps are shut down, the external drive will receive enough power through connector port, but when you launch djay pro it requires so much power to run the app that the ipad can’t route enough power through the connector port.

For me it’s looks like the external ports will go to “sleep mode” if something else requires more power.

Hmm. Just shut down every app, and used an ultima micro-ssd using a powered USB - same thing. I’ve also tried using an SSD reader without joy.

Edit: for reference, the same ssd also works without issue in the native iOS files app. Also, with the drive plugged in, the name of the drive is highlighted and shows up “bright white’. Unplug the drive and it turns grey. It looks like it’s detecting the drive correctly, but it doesn’t reload the file list.

What have you done to isolate the problem to the Djay app, are you sure that the problem isn’t your ipad connector, one of the cables, usb hub?

You need to be more specific to describe your situation.
You haven’t even describe what kind of setup you have and what have you tested.
Is your external hard drive HDD or SDD or M.2 or what?
What ipad model, list of otehr equipment, cables, picture of your setup etc could be useful.

How to isolate your issue like this, ie. start with simple device like 32/64 GB usb stick:
Test 1: 32 GB / 64 GB usb stick, plugged to ipad, does it work with file browser
Test 2: same 32 / 64 stick, plugged to ipad, does it work with dj pro
Test 3: same 32 / 64 stick plugged to your usb hub, does it work with file browser
Test 4: same 32/64 usb stick, plugged to your usb hub, does it work with dj pro
Test 5: same 32 / 64 stick plugged to your usb hub, usb hub connected to “wall”, does it work with file browser, is your ipad charging
Test 6: same 32/64 usb stick, plugged to your usb hub connected to “wall”, does it work with dj pro, is your ipad charging

And then you also need to consider what kind of file system your usb storage have. Test the all supported file systems and repeat i.e 1-6 again.

And repeat the test 128 gb usb stick, and with your “old external storage” and this “new external storage”.

And perhaps repeat 1-6 with different usb cable connecting the external storage to your system.

Ok - I’ve tried with 3 different USB devices: a memory card reader reading from a new 512 GiB SSD. A hub with USB and card-reader built in, trying to access 2 different SSDs (both 512GiB). I’ve also tried with a memory-card reader that I use for my camera. Then I tried accessing a new 2TB Seagate drive (powered) through both of the USB hubs. I’ve also tried using the hub my MacBook Pro uses.

In all cases, the drive shows (turns white), then goes grey with “no music”. With a new drive (one that djay hasn’t seen before, I get a processing indicator before “no music appears”. The drive/folder indicator remains white, suggesting that it’s seeing the drive, but not reading the music.

All the above devices, connected via any of the USB hubs (all with their own wiring built-in, so different cables in each case) open perfectly in the built-in files app. I can play tracks within that app too.

The iPad (Pro, 2020, iOS 14) charges with both of the hubs, clearly not with the SSD card reader.

I note that the settings does not include an option for accessing files … other apps do. Could this be the problem in iOS14’s new security model?

Why you don’t just start with simple small USB stick as I proposed ie. 32/64GB?

You need to first figure out if your system works with at least something. Even if it’s crappy old stick from 2010, but then at least you have one reference that the stick works directly connected to your ipad and connected with all of your hubs.

Just don’t try those big boys first.

And google is your friend for some other tips

Micro SSD in a USB SSD reader? That’s too complex?

It all worked until iOS 14. The files app works. The hardware’s fine, this is a djay issue.

That video also refers to old iPads. This doesn’t use lightening. Google’s not my friend in this case - there’s nothing on there relating to djay not reading files.

I’ll say again - the files app in iOS works without issue. I see folders and files and can play any track without issue: switch to djay and the drive shows up as connected but with no music available. Switch back to files, select a track and play it in files … no problem. Back to djay … no music.

Finally, I got some answers :smiley:

So it has worked in iOS13, so your ipad and djpro worked then with all of your external storage solutions.

And after you update to iOS 14, none works?
Or is there still some device which works?

I’m just trying to help you to gather enough info for customer support, but you are failing to describe what exactly works and what not.

As in the video he tries to explain some of the problems he have had. I.e some devices requires so much power/energy that they refuses to work correctly and have mysterious side effects like the one you try to solve.

So yes, it might be iOS 14 issue, but then you should be able to find related problems using google.

So if it’s djpro problem, some other user should have had the problem as well and commented on this.

Good luck to solve it.

Thanks. Yes all worked for iOS13. Yes, all devices work on the iPad outside of djay.

So - can I back up the SQLite DB files by copying the user data folder off the iPad, delete the app and reinstall, then put the user data folder back, or will that lose the tagging and playlists?

I made a copy on the desktop and can open the DB and see the data. The hardware works - and nothing’s changed there - the DB opened without issue so I suspect this might be a permissions issue with the app. If I delete and reinstall, would that force it to reset the iOS access requests again?

Good information thanks for sharing