IOS9 on IPAD2: Djay2 in combination with Pioneer Wego3 not working

It works for a couple of seconds and then communication is lost with the cotroller. Sometimes it works longer…

Djay app crashes with wego 3 randomly… Same problem iOS 9 and THE power light om and no responce think there is gonna be a fix?

I am using IOS 9.2.3 on my iPad 3 with Djay 2 and Djay Pro and with the DDJ-WEGO3. It works fine.

Please have a check if your controller is broken. Therefore, download “Midi Monitor” at the App Store, connect your Pioneer Wego 3 and wait for djay 2 to stop responding. Now, launch Midi Monitor and see if it responds to hitting some controls on your Pioneer Wego 3. 

The controller can be broken anyway. Please do the testing.

It is not the controller. It works perfect with Iphone 5s and virtual dj on the pc.

I have installed MIDI monitor. It looks that the IPAD is stopping to send MIDI commands to the controller. If I do the same on a Iphone4 it works perfect. So it is not the controller or cable. There is something wrong with the IPAD. Any reports on MIDI problems in combination with latest IOS?

I have a similar problem. Wish I never updated to IOS9. At Random when I turn on my wego3 while it’s connected to my ipad; all the lights on the wego3 go out except for the green power button which I then can’t turn off and then have to pull the power cord from the wego3. Everything was fine with IOS8. If ain’t broke don’t upgrade!

So the problem I described above has been happening less frequently. I had no problems when I did a 4 hour party. No problems when I do my hour radio show every week. I notice the wego3 freezes sometimes when I’m playing music from the Spotify app. I have version I’m going to upgrade spotify to 4.3 and see what happens.

Hello, I am having same issue, work with my mac but not my ipad? I checked all connections, also with lighting adaptor all work but will not respond at all to DJAY software. I open the app and get nothing? what happened?

Hi Frequenze Indipendenti,

does that mean two devices are not working with the WeGo3? 
The WeGo3 is running with the latest iOS versions without a problem, this sounds more like a cable/hardware issue.

Are the devices charging? If not could you download the “Midi Wrench” application and see if the connected controller is sending midi devices?

Thank you in advance.

Lukas E.

Hey there,

I am sorry to hear that. Would it be possible to update your iOS version to see if the problem is persisting? 

I’m using my iPad3 Wifi/GSM 32 GB with iOS9 and I’m just before buying a Pioneer Wego-3. Unfortunately I heard about that bug and I’m searching for a solution before my investment.
When will a fix be available?

Any News?!

We-go 3 / Djay 2 on IOS 9.2, 9.3…

Did you solve the problem?!

Before I got an iPad Air 2 to use with my WeGO4, I was using an original iPad Mini running iOS9 with it without any problems, then I got the iPad Air 2 with iOS10 and djay 2 wouldn’t detect the WeGO4.

I tried many different things and eventually got it working after performing the steps below and the two devices have remained working normally ever since.

Try these steps to see if it resolves your iPad and WeGO3 issue:

  1. Uninstall djay 2
  2. Reset settings on iPad
  3. Reinstall djay 2
  4. Connect iPad to the WeGO without power to the WeGO
  5. Connect WeGO to mains
  6. Power up WeGO
  7. Open djay 2

Here’s my thread for reference:…

I have the similar issue to the ones already explained. However I have a iPad 2 which was working fine with algorithm using the official pioneer cable for the older style connection (not lightning). Now when I connect the cable it connects and charges an the “pioneer dj” logo come up an everything works fine. For about 10 seconds that is, then I get a beep sound from the iPad an it continues to charge the iPad but disconnects from being able to control algorithm and sound stops going through master out an comes out of iPad ? But what is really confusing is that it continues to charge ??? I have changed the cable an tried the Lightning cable that came with it on my iPhone 7 an everything works fine. I am pissed that I can only use it with my phone that has a much smaller screen to my iPad. Not sure what has gone wrong as it worked fine about 9months ago.

Please see my comment below, I hope there is a fix as I seem to have the same issue as jurgen