iPad 13 Air & Reloop Buddy - No Audio

Just bought an iPad 13 Air running iOS 17.5.1 with the Reloop Buddy running Djay Pro v 5.1.7.

I’ve connected exactly as it’s supposed to on the iOS approach. Have speaker connected to iPad via Bluetooth and headphones plugged into reloop buddy. Just can’t get it working properly:

Won’t detect the reloop buddy
No sound from speaker
Cueing in headphones not working

Have tried connecting on the PC approach but still no luck.

Had MacBook before this and it was so easy and everything worked.

Hi @Richwalden,

  1. I do not recommend connecting your speaker to the iPad via Bluetooth. This will result in a noticeable delay in the audio signal due to Bluetooth latency. Instead, I recommend you connect your speaker to the RCA outputs of the Reloop Buddy instead.
  2. How exactly are you connecting the Buddy to your iPad?
    a. Are you using a USB-B cable connected to the Power socket on the Buddy or a USB-A cable connected to the iOS socket on the Buddy?
    b. Is the PC/iOS switch on the side of the Buddy set to the appropriate position based on the socket you are connected to above?
    c. Are you using any kind of a USB hub or adapter to connect your USB cable from the Buddy to the iPad Air?
  3. With your Buddy connected to your iPad, please navigate to the djay Settings>Audio Devices and share a screenshot of this page.
  4. Also, navigate to the djay Settings>MIDI Devices and share a screenshot of this page. Thanks!

1 Like

Thanks for the screenshots @Richwalden. This is very helpful. Based on this screenshot, there appears to be an issue with your USB connections between the Buddy and iPad.

  1. First, try pressing the Rescan for MIDI Devices button near the bottom. If your Reloop Buddy does not show up in the MIDI DEVICES cell, please try the following.
  2. Disconnect all cables and adapters from your iPad and DJ controller.
  3. Close djay.
  4. Perform a Forced Restart of your iPad.
  5. After restarting, connect your USB-B to USB-A cable to the Power socket on the Buddy and to your original Apple iPad charging brick. It’s important to use your original Apple charge for this to ensure the Buddy and your iPad receive enough power.
  6. Make sure the PC/iOS switch on the Buddy is set to iOS.
  7. Connect your USB-C to USB-A cable between your iPad and controller.
  8. Confirm that your DJ controller powers up and your iPad is charging normally. If not, disconnect the cables and try again.
  9. Launch djay.
  10. Open the djay Settings>MIDI Devices and confirm that your controller is shown under MIDI DEVICES.
  11. If not, scroll down to the bottom and press Rescan for MIDI Devices.
  12. If this doesn’t work, unplug the USB cable from your DJ controller for a second then plug it back in.
  13. If this doesn’t work, then the problem is most likely with your USB-A to USB-C cable. Please note, that not all USB cables are created equal. Some only work for charging and cannot transmit data. If you have a genuine Apple USB-A to USB-C cable, you should try that.

Thanks. Just one thing on the usb an and usb c, the cable I am using I plugged into iPhone and the djay software on that recognised the buddy.

Thanks for the info @Richwalden. That’s a good sign…

If the above procedure doesn’t work then do the following:

  1. Access the iPad Control Center by swiping down from the Top Right side of your iPad screen.

  2. From here, select the speaker icon and in the next screen make sure the Reloop Buddy is selected instead of iPad or your Bluetooth speaker.

Hi. So we have success connecting. The cueing works in the earphones plugged into buddy. But no sound from speaker plugged in to buddy. This is what the audio settings shows.

It’s ok I’ve sorted that now. Thanks.

Excellent. You’re welcome @Richwalden. I also recommend that you turn Bluetooth Off on your iPad so your speaker doesn’t accidentally connect wirelessly.