Ipad Air 1 iOS 11 bricked when trying new browse files function in Djay 2

Hi, during a session, i wanted to see if i can load some files from files, and when and when i hit the “files” button in the browse local music section, my iPad totally crashed. I tried holding the power and home buttons for 45+ seconds as suggested, i tried to do recovery from iTunes on a MacBook, and again the iPad has zero response. not showing that it is charging, no mac icon, nothing.

Does anyone have any suggestions on how to turn it back on?

Prior to trying the explore the new files function, everything was working fine, and I was in the middle of a gig when this happened.

FWIW this is seemingly coincidental. I would contact Apple themselves as this is not a typical Djay SW related question. Best of luck though.

Just putting this out there though have you made sure to use an actual Apple lightning/USB cable along with an actual Apple adapter? Short of sounding like an Apple salesman I can promise you after YEARS of HEAVY Apple ecosystem use the cables & chargers are MUCH more critical than some thing and one of the leading causes of real issues from grounding, recognition, bandwidth to straight up compatibility & function.