Is there a way to disable trackpad scratching?

Is there a way to disable trackpad scratching? Or make Djay Pro adhere to my trackpad settings in my system preferences? I have been inadvertently scratching the playing deck when my palm rests on the bottom edge of my MacBook

Hi DJ Supe,

Thanks for posting in our Community.

It is currently not possible to disable trackpad scratching on djay for Mac. We apologize for the inconveniences this might have caused you.

I’ve forwarded this request to our developers and they’ll look into integrating this request in future updates. I’ll keep you posted here with any updates as well.

Let me know if you have any further questions.

Cheers,G

Any feedback on this?

Not yet djsupe, we kindly ask for your patience. I’ll personally hit you up when this is implemented. Thanks for your understanding.

Cheers,G

It is possible to disable this. Simply delete the MIDI mapping for the jog wheel scratch.

Tip: It is still possible to scrub/search through the track by holding SHIFT and turning your Jog.

So disabling the jog wheel scratching by deleting the midi mapping will also disable the trackpad scratching?

You can check this yourself. Got to settings → MIDI → edit mapping.

Then touch your trackpad. Then you an see which MIDI signal is sent and where it is mapped to. The view automatically jumps to the corresponding mapping. Then you can delete that mapping.

(I now this works for hardware controllers. I am not quite sure if it also works for your laptops touchpad/trackpad)

I hope this helps.

1 Like

Typically trackpads are omitted from midi mappings as that is a system level input. I confirmed this by simply looking in the Shortcuts menu. The menu path you indicated does not exist in the 3.1.6 btw