Kontrol S2 Midi mapping settings not saving.

Djay not saving my custom map settings for my Kontrol S2.
i set up everything like i read and when i close the page where i set my custom mapping they work, i close out of DJay and reopen it and my settings aren’t gone, ive never recieved any kind of “do you want to save these” setting before and i read that it just autosaves, plus i have the custom settings files in my djay midi mapping folder, care to help me please?


How did you close the page? Did you click “Done”?

Also, which files can you find under Music/djay/MIDI Mappings? How old are they?

What happens when you select a different mapping? Try to edit your mapping and check whether djay saves a new file.


Please delete the entire “MIDI Mappings” folder and try again.

I understand that you want this issue resolved as quickly as possible and I do too. But, I do need some time to figure this one out and also to check back with our developers.

Can you please send one of the mappings to support@algoriddim.com?

Also, please download MidiKeys and check if you can save a mapping for this “controller”. http://download.cnet.com/MidiKeys/300…

Thanks for sending your MIDI mappings.

The mapping files look fine. The weird thing is that you have more than one mapping file for the same controller.

Please delete all your MIDI mappings and then make a video recording of how you create a new mapping for your cotnroller. Also, please open the “Console” app and search for “djay” on the top right corner. Are there any entries there?

Please open the Console app (under Utilities) and then connect your controller. Are there any entries there (e.g. something like “Added MIDI controller…”)?

Thanks for posting this Shawn.


Sorry that it took so long but we finally found the bug and fortunately also a workaround until we get this fixed internally.

The problem is that the identifier in the mapping file is somehow incorrect.

So, please do the following:

  • Open the mapping file with TextEdit (drag and drop on the TextEdit icon)
  • Somewhere at the bottom of the file, you’ll find something like this:
<string>Traktor Kontrol S2 Input</string>   
  • Change the bottom line to:
<string>Traktor Kontrol S2</string>   

If you are using a different controller with the same issues, try removing suffixes so only the actual controller name remains.

I just tested this with our S2 and it worked.

Ctrl-click on the mapping file and open it with TextEdit.

Yes, i click done everytime. Though it gives me no option to save the configuration when i close out of Djay when im done with my session.
they say they’re djay mapping files and theyre all from yesterday because thats when i downloaded your software. i made sure i had all the current drivers with my S2 so that shouldnt be the issue.

nothing, they’re all blank. the mappings are saving as blanks template. when i open a different one nothing changes. Every time i plug my s2 it recognizes it as a new controller not one that had ben pluuged in before with mappings already set.

I did that and it didn’t work, so i then i uninstalled the program and reinstalled it.
and tried it again and it didn’t fix anything.

When i go to the midi mapping folder and try to open the mapping like that it shows up blank and im not sure why its doing that.

Could it be a traktor issue?
i really dont wanna do a config everytime i open the program.

thanks for…not helping.
if that’s the case can i get my 10 bucks back?

Well, i tried midi keys and the mappings saved for that controller. and i tried the keyboard within logic and that saved as well, so im not sure why my s2 savings aren’t saving

I am having the same problem - I have three traktor devices - two of which I was using actively with the previous version of DJay 4 - after upgrading to the latest version in the app store this problem has occurred.

I have an S2, X1 and F1 - The S2 settings are not loading - I have deleted the file and redone it and it still won’t load - the device is detected as new at the next start of the djay 4 application.

I have checked the S2 midi mapping file and it is fine. I have put a backed up version of the file in the directory also - same issue - it refuses to load.

The weird thing is my X1 mappings are fine and continue to load and work.

As an experiment I set up mappings for my F1 and they suffer the same issue as the S2. They won’t load when Djay is started but the midi file is fine. Basically if I want to use the F1 or S2 I have to do the mappings again with the expectation of losing access to the mappings next time I start DJay - very frustrating since it is a lot of work to do the mappings each time…

I use the S2 controller all the time - this is a problem to say the least.

This is what I see when I connect the S2 in console:

12-08-26 9:32:35.768 AM Firewall: CodeMeterMacX is listening from proto=6
12-08-26 9:32:36.366 AM MouseWizard: *** Assertion failure in -[NSTextFieldCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-1138.47/AppKit.subproj/NSCell.m:1564
12-08-26 9:32:40.000 AM kernel: USBF: 16339.941 Traktor Kontrol S2[0xffffff8014cc3c00]::joinPMtree - could not find the hub device
12-08-26 9:32:40.000 AM kernel: USBF: 16340. 80 IOUSBInterface[0xffffff8014cbd600]::joinPMtree - could not find the hub device
12-08-26 9:32:40.769 AM Firewall: CodeMeterMacX is listening from proto=6
12-08-26 9:32:41.700 AM VDCAssistant: VDCAssistant: Found a camera (0x2640000017cc1100) , but was not able to start it up (0xe00002c0 – (iokit/common) no such device)
12-08-26 9:32:41.700 AM VDCAssistant: VDCAssistant::DeviceArrived Got error (0xe00002c0), waiting to see if the device shows up again
12-08-26 9:32:44.703 AM VDCAssistant: VDCAssistant: Found a camera (0x2640000017cc1101) , but was not able to start it up (0x0 – (os/kern) successful)
12-08-26 9:32:44.703 AM VDCAssistant: VDCAssistant: Found a camera (0x2640000017cc1101) , but was not able to start it up (0x0 – (os/kern) successful)

That is directly connecting the device to my Mac Laptop

As a comparison this is what my X1 shows when connected to console - obviously it doesn’t create any messages and the device initializes - the lights come on etc. If I start DJay it is recognized and works unlike the S2.

12-08-26 9:34:25.789 AM Firewall: CodeMeterMacX is listening from proto=6
12-08-26 9:34:30.789 AM Firewall: CodeMeterMacX is listening from proto=6
12-08-26 9:34:35.790 AM Firewall: CodeMeterMacX is listening from proto=6
12-08-26 9:34:36.359 AM MouseWizard: *** Assertion failure in -[NSTextFieldCell _objectValue:forString:errorDescription:], /SourceCache/AppKit/AppKit-1138.47/AppKit.subproj/NSCell.m:1564
12-08-26 9:34:40.791 AM Firewall: CodeMeterMacX is listening from proto=6

Just a note: The S2 will work just I have to re-map the midi mappings every time I start DJay (note: I did this last night for a gig… pita and just glad I didn’t have a crash or needed to restart DJay mid set.)