Label column not sorting correctly

macbook pro 2.3 ghz 8 core i9 , sonoma 14.3.1, 16g mem.
djay 5.1.7
ddj 400

Label column not sorting at all.
CLick on the Label column and nothing happens.

Hi @Donn, please try logging out of all streaming services within djay then close the djay app and reboot your Mac. Can you also confirm what the source of this music is (local mp3s, TIDAL, Beatport, etc.). Thanks!

Hi Slak_Jaw, I’m not using any streaming services. I have only local
mp3’s and m4a files (no ext. hardrives). Thanks!

Hi @Donn, okay, thanks for confirming. Do you know if this is new issue in 5.1.7 or if it has been around for a while?

It’s been at least 3 to 4 versions back. I was running out of tag columns
and tried to use it not as a record label but another organization tag but
it never worked.

Thanks for the additional info @Donn. I’ve passed this onto the engineering team to see if they can replicate it.

Hi Slak_Jaw, forgot to mention when doing a search for a Label tag, no results come up and all the columns disappear after hitting return. I attached an example

Hi @Donn, the engineering team has identified the issue. This will be fixed in an upcoming update. Thanks!

Hi Slak_Jaw, I noticed when searching for Composer or Comment i’m not getting results.
I did a test where I tagged a song w ‘test composer’ in the composer column and ‘test comment’ in the comment column.

I searched for ‘test composer’ while in a Playlist w the ‘search library’ icon OFF w no results from coming from Music , searched while in Music w ‘search library’ OFF and On, w no results.

Same goes for ‘test comment’ but I did get one result if I’'m in Music and the ‘search library’ is ON.

btw, something strange going on w the Filter for Release Date. For example if I set ‘is’ 1/1/01 or any date, it doesn’t show but if I set ‘Not’ 1/1/01 then all the release date 1/1/01 show.

Thanks!

Hi @Donn, thanks for the additional info. I’ve passed this onto the engineering team.

Hi again @Donn, regarding the release date issue, could can you please upload one or two of the affected files to your Google Drive/Dropbox, enable sharing permissions, then share a link to the file(s) here or send it to me in a DM? Thanks!

Hi again @Donn, just following up on this post above. Thanks.

Hi Slak_Jaw, i took a few screenshots and the title describes the problems. Basically none of the filters work for the release date, and also when searching a release date there’s no results.
Thanks.
(btw I just noticed the title of the screenshots aren’t displayed w the jpeg but if you position the mouse over it or expand you can see it)





Thanks for the additional info @Donn

Hi @Donn, text search for release date field is not supported, but filtering should work. Could you please share your djaymedialibrary database so engineering can take a closer look? Thanks!