Loop IN, OUT and AUTO LOOP with MIDI mapping Not working properly now

Hello, I have used a Novation Mini Launchpad MK3 for some time now to MIDI map different features in DJAy Pro.

This has worked quite well up until recently.

Now this seems to be happening:

  • when the Loop In, Out and Auto Loop are selected while using some button on the Novation controller (that I had previously mapped for any of those features), it does Not work properly.

Per instance, when I press the Auto Loop button (using the MIDI controller), it does nothing. If I press auto loop on the iPad’s screen, it works.

If I press the MIDI buttons corresponding to Loop In and Loop Out, even though I see the new section on the waveform, the song keeps playing as if I had not selected a loop in and out. If I use the buttons on the ipad screen though, it does as expected: it starts a new loop within those limits.

What do you think may be happening and how can I fix this?

Thanks, looking forward to feedback or solutions,
Ricardo

  • Device model: iPad Pro 2017
  • Version of operating system: 17.3.1
  • Version of djay: 5.1.3
  • Hardware/controllers used: Novation Launchpad Mini MK3
1 Like

Hi @Ricardo_Pereira, to better help me troubleshoot this issue with you, I’ll need some more information.

  1. Are any of the buttons on your Launchpad working with djay or is it just the Loop controls?
  2. How exactly are you connecting the Launchpad to your iPad?
    a. Are you using an official Apple Lightning to USB Camera Adapter or a 3rd party adapter?
    b. Is the adapter connected to power with your original Apple charging cable and charger?
    c. Is your iPad charging normally?
    d. Are you using a high quality USB cable between the adapter and the Launchpad?
    e. Have you tried a different USB cable?
1 Like

Hey @Slak_Jaw , really appreciate your prompt support. Let’s answer your questions then:

  1. there are other buttons in my Launchpad Mini working properly with other mapped functionalities. So, short answer is yes. What I am noticing is that the controller seems to be working well, in and of itself, as usual because I see stuff happening on Djay Pro as I press those buttons but what it seems to be happening is Djay Pro Not being able to use correctly the MIDI mapped commands. The app is definitely receiving the commands though, just does Not seem to be using them correctly as before. Erroneous behavior is what seems to be happening with those commands.

Attached is a video where I demonstrate the anomalous behavior, including

  • loop in and out section showing up on the waveform but without triggering the loop to actually stray.
  • auto loop section showing up on the waveform when I press the button on the controller but Not actually triggering the loop to start (song just keeps playing regularly)
  • Another apparent bug is that auto loop “half loop” and “double loop” buttons make the loop interval go from 1 - > 4 - > 16 instead of 1, 2, 4, 8, 16
  • “Select next FX” and “select previous FX” also seem to jump positions between the available list of effects as opposed to going forward and backward one by one in the whole list of effects. You can also see this on the attached video.

a) Yes. Using an official lightening Apple adapter (the one that has 2 slots: one for usb and one for the lightening cable to recharge)

b) Yes, it is being charged with official Apple charger.

c) Yes, my iPad is charging regularly.

d) Yes, I am using the original usb cable that came with Launchpad and worked correctly up until recently.

e) Not yet. Have no reasons to believe it’s the cables’s fault though due to all other data presented here.

Below is the video with some of the apparently malfunctioning behavior:

Thanks for the support. Again, really appreciate it and Look forward to hearing from you soon.

Hi @Ricardo_Pereira, thanks for the additional information. I suspect it could be a problem with your custom MIDI mapping or USB cable, but before we check those let’s try the following:

  1. Disconnect your Apple Camera Adapter, charger and USB cables from the iPad and Launchpad.
  2. Close djay and all applications on your iPad.
  3. Perform a Forced Restart of your iPad: Force restart iPad - Apple Support (CA)
  4. After rebooting, launch only djay.
  5. Now connect you Apple Camera Adapter to the iPad.
  6. Then connect your charger cable and charger to the Camera Adapter and confirm that your iPad is charging.
  7. Now connect you Launchpad to the Camera Adapter with the USB cable.
  8. Check to see if the issue persists. If not, great! Use the above connection sequence in the future.

Hello. Thanks for the suggestions.

The issue keeps happening. Followed all the suggested steps by you. Also tried a different usb cable and issue persists.

Still seems like a bug to me: other MIDI mapped features to this controller on the Djay Pro app work well, and controller works just 100% with other apps (and used to work 100% well with Djay Pro up until recently).

  • The MIDI mapped features which continue working INAPPROPRIATELY are 1) Loop In 2) Loop Out / Off, 3) Auto Loop 4) Loop Half 5) Loop Double 6) Reloop / Loop Off

Looking forward to hearing from you about what may be going wrong or a solution.

Thank you, sincerely appreciate the guidance and solution.
Warm regards, Ricardo

Thanks for the update @Ricardo_Pereira. Sorry that didn’t work.

  1. Did you MIDI map the Launchpad yourself or download someone else’s?
  2. Have you mapped any new functions recently or made any changes?
  3. Do you have any other MIDI controllers connected at the same time?
  4. Can you please share screenshots for the MIDI Mapped controls that are not working (Loop In, Loop Out/Off, Auto Loop, Loop Half, Loop Double, Reloop/Loop Off)?
    a. In the MIDI Learn tool, press the button that isn’t working properly to reveal the MIDI assignments and expand the Advance Control Configuration.
  5. Also check through the list to make sure you haven’t accidentally mapped the same MIDI CC or MIDI Note to multiple functions.

Thanks!

1 Like

Hey! Let’s keep moving forward here :smiling_face::pray:t4:
Answering your questions :point_down:t4:

  1. I was the one that MIDI mapped any functions. There also have been No recent midi mappings that I am aware of. Incoherent stuff like this started happening, I would perhaps assume after some kind of update. It was working quite properly before.
  2. Not to DJay Pro, no. I do use this same controller for a different app as well (Loopy Pro), and I’ve done that since the beginning with No trouble whatsoever. Nonetheless, each button is ONLU configured to one function on either one app or the other. There are No same buttons firing different stuff either on the same app or different one…
  3. Yes, always have since the beginning as of several months now.
  4. absolutely. I’m sharing in video format and you’ll hear my voice walking you through it as well.
  5. Done. Seems like this is Not the case.

Screencast Winford you requested

Take care

Hi @Ricardo_Pereira, thanks for the video. This is very helpful. It appears to me that your controller is somehow sending the same MIDI command twice with a single button press. So when you press Loop Out/Off it adds the Loop Out point then immediately exits the loop. Same with your Autoloop. This typically means that you’ve duplicated these commands within your mapping so that one button press actually equates to 2 button presses at the same time. I recommend you try the following:

  1. Make sure only your Launchpad Mini is connected to your device and no other apps are running (just djay)
  2. Create a new blank MIDI mapping for this controller from scratch.
  3. Only MIDI map the Loop In and Loop Out/Off buttons to your controller.
  4. Test again with only these 2 buttons mapped.
1 Like

Also, I’ve never used the Launchpad Mini, but is there a setting for the hardware via a Novation utility tool that allows you to adjust the velocity sensitivity and MIDI outputs? Perhaps you have changed a setting somewhere that has enable multiple MIDI command outputs or something.

EDIT: Actually, after watching your video again, I noticed that you are showing 2 Launchpad Minis in the connected MIDI Devices. I think this could be the problem and be the reason for each button press being duplicated.

1 Like

Awesome job dear @Slak_Jaw 🫶🏼

Indeed each midi mapped control was being triggered twice without my awareness. Even though both these 2 different names of mappings of the Launchpad controller (“Daw Out” and “MIDI Out” showed up since the beginning, as of quite a few months ago when I started mapping it, only 1 of them was being used by me to map controls for quite some time but somehow the 2nd one became used as well, and duplicated, without my awareness.

I have just erased all the entries in one of them, so only 1 of those mappings “Daw Out” remains now active with controls as opposed to both “Daw Out” and “MIDI Out”.

Challenge solved :clap: :clap: :clap:
You got a happy customer here wanting to get back to having fun with DJing. Thank you, keep enjoying your ride, I loved how you payed attention to details.

1 Like

Excellent! You’re very welcome @Ricardo_Pereira. Glad I was able to sort it out for you.