M-Audio X-Session Pro in 2021

I’m using an M-Audio X-Session Pro on a HP Pavillion laptop with Djay Pro for Windows. Whenever I plug it in the controller appears twice when i click into Configure MIDI Device. Anyone got any ideas why? I end up needing to remap the controller every time i plug in, twice. My settings are never saved!

Age of device? Tried updating drivers but all showing as up to date. Trying today to upgrade Windows (Creator update) to solve another issue.

I don’t know exactly about the controller in Djay. There should be a mapping file in Djay and a way to save it. I believe it is in the MIDI tab at the top of the app., but I do want to take a moment to reminisce about M-Audio Torq. I really thought in many ways it was ahead of it’s time, it was a lot of fun: tempo synced loops and samples that worked pretty well.

Hey :wave:

In order to add a new mapping to djay PRO for Windows. Please follow these steps:

  1. Go to this folder %LOCALAPPDATA%\Packages\59BEBC1A.djayPro_e3tqh12mt5rj6\LocalState\Library\Algoriddim\

  2. If it doesn’t exist, create a new folder and name it “MIDI Mappings

  3. Add the MIDI mapping to this folder

I hope I could help.

Let me know if the mapping is still being deleted then.

Cheers, G