M1 iPad Pro and Rane One

Greetings,

Is anyone using an M1 iPad Pro with a Rane One?

The app recognizes the controller but it is very slow to respond to input.
I’ve reached out to Algoriddim and was told to send a video. I will send a video; just wondering if I am the only one with this issue.

Thanks

kp

Probably not helpful to your issue but I have an ipad 5th gen and ipad 6th gen and the waveforms on the 5th gen are definitely laggier than the 6th gen.

Hey @klp45,

Thanks for joining our Community! I’m sure you’re going to like it here:)

It would be great if you could record a video @klp45 so we can all assess the responsiveness.

Are you using the USB-C Multiport by Apple?

Cheers, G

Yes, also tried Apple USB-C-to-USB Adapter.

Is it the visual representation of what you are doing that’s slow to respond, or the sound output? If the later I was caught out because my speaker had high latency

1 Like

That’s a very good point @Private_Repress :eyes: thanks for joining this thread :wink:

@klp45, does the lag/latency change when you scratch/beat juggle?

The problem could be related to your other audio hardware. Generally, we recommend using shielded cables with ferrite beads.

Looking forward to the video.

Cheers, G

1 Like

HD is still processing at the time of posting.

Oh… :hushed: Let’s get to the bottom of this !!

As we haven’t been able to reproduce this issue, we need your help. It would be very helpful if you could send us your iPad logs. Don’t worry it’s not hard to get them, I’ll guide you through it.

You will need a computer to access the logs.

On Mac:

  1. Connect your iPad with your Mac via USB
  2. Open “Console” on your Mac
  3. Select your iPad under “Devices”
  4. In the search bar in the top right corner, type “djay” and press enter
  5. Open djay on your iPad
  6. Reproduce the issue you’ve described
  7. Copy & paste the content of the Console app on your Mac

On Windows:

  1. Install iTools on your Windows machine
  2. Launch iTools
  3. Connect your iOS device to the Windows machine through USB
  4. Click on Toolbox
  5. When you are ready to reproduce the issue in djay on your iPad, click on Real-time log under Advanced Features. You can see the logging happening in real time
  6. Click on Save to save the log activities
  7. Copy & paste the content of the log on your PC

Then send us the logs to this email address support@algoriddim.com and I’ll take it from there.

I’m sure that with your collaboration we’ll be able to fix this very soon.

Cheers, G

Solved: After doing a complete wipe of the iPad it is working fine. If I do find the cause, I’ll post it here promptly. Thanks to all those who helped.

kp

2 Likes

Hey @klp45,

Thanks for letting us know that you managed to solve the problem by resetting your iPad. It’s odd that that would solve the issue but - if it works, it works! We wish you happy mixing:) :headphones:

Let us know if you ever encounter any other issues with the RANE ONE and the M1 iPad. We’ll be happy to further assist you.

Cheers, G

1 Like