macOS: "Title could not be loaded" djay 5.1.3 & 5.1.5

Hello Slak_Jaw Is an update to version 5.1.6 for macOS also planned? I’m experiencing the same issue on my Mac.

macOS 12.7.4
MacBook Pro Retina 15" 2015
djay Pro 5.1.5, but the problem was also present in version 5.1.3, and I was hoping for an improvement with 5.1.5.

Error message: “Title could not be loaded” – there was a problem accessing the file.

The title plays without any issues in the Apple Music app (formerly iTunes).

Thank you very much for your effort.

Hi @grand91,

  1. Can you please confirm the source of music where you get this error message?
  2. Is it with Local Music mp3 files stored on your Mac internal drive?
  3. Can you please try loading the same file via drag & drop from the Finder to see if that works. If yes then maybe removing and re-adding the file to the Music app could help. Thanks!

The error message appears with my locally stored music, which I have added to Apple Music (iTunes). The music is stored on an external SSD (SanDisk Portable SSD 1TB).

When I manually drag the title into the deck using right-click (show in Finder), it loads and plays. However, it does not work directly from the DJ Pro app.

I have also tried copying the tracks from the playlist and saving them in a folder on the desktop, then creating a new playlist in Apple Music (iTunes) and adding these titles to it.

Still, the same error occurs.

I would now say that the error mainly occurs with newly added playlists in Apple Music (iTunes)… but not with all songs in the playlist.

Even in older playlists, some songs cannot be loaded.

However, the error has only occurred since version 5.1.3.


Thanks for the additional info @grand91. This sounds like a different issue so I have created a new topic to discuss it.

1 Like

@grand91, please try removing some of the tracks you are having issues with then re-add them to the Music app to see if that works.

1 Like

I have saved the songs from the Apple Music playlist (iTunes) locally on the internal hard drive on the desktop in a folder. I then added this folder to the Apple Music (iTunes) library and also loaded the songs into a playlist.

I restarted the MacBook in the meantime, launched djay Pro, and updated the library. Streaming services Apple Music and Tidal are turned off.

Songs from the newly created playlist still cannot be loaded into the player with the same error message. Manually from the Finder folder via drag & drop works without any issues.


Thanks for the additional info @grand91.

  1. Please check what Apple Music says in Get Info → File section for the tracks.
  2. If the app says cloud status: Apple Music then the Apple Music app thinks this is a streaming track, not a local track.

Streaming track example:

Matched local track example:

i don’t have the line with cloud status

I’m having the same issue,…

with tracks i’ve been playing for YEARS!

1 Like

Thanks for the info @Buddha_Stretch

  1. Please check what Apple Music says in Get Info → File section for the tracks.
  2. If the app says cloud status: Apple Music then the Apple Music app thinks this is a streaming track, not a local track.

That isn’t the problem

Same issue here. It seems to only be playing songs that are purchased. Not songs imported. I don’t have that cloud status either. Damn update

Thanks for the info everyone. I have forwarded everything to the engineering team and they are investigating it further. I’ll report back when I have news. Thanks!

1 Like

I have the same issue after upgrade. it is local file and dropping it from the finder in Mac OS works. this is very unpleasant upgrade

After update to 5.1.5 I cannot load local tracks: “Could not load track” “There was a problem accessing the file.”

  1. Djay Pro 5.1.4 had now problems load tracks at all.
  2. Tracks from Apple Music do load
  3. Apple Music does play the tracks from the external ssd
  4. After restart nothing changed
  5. Djay knows where to find the track: right click “show in finder” is available
  6. Djay does load the cover image, track title, artist: but no bpm or key and no waveform
  7. “Preview Track” does not work on local tracks: is greyed out
  8. Dragging a local track from ssd into Djay Pro does load correctly
  9. After that (8.) the track can be loaded from within Djay Pro correctly again.
  10. Other local tracks still DO NOT load after point 8.
  11. Info pane (library sidebar) does show the waveform of the local tracks but does not preview/play them

Trying to solve this: Replaced the Library with yesterdays version
12. Track not available - Relink Missing Files… button
13. Makes all local files greyed out (unavailable, right click=Relink missing files)
14. Choosing “Relink Missing files” shows a strange extra Volume that I don’t have: Djay Pro lists two external Volumes:

  • “/Volumes/USB1TB” (showing original icon)
  • " /Volumes/USB1TB 1" (showing a finder folder icon)
    The second volume “/Volumes/USB1TB 1” does not exist. (checked via macOS Finder, “Go to Folder”, /Volumes)
  1. Click “Allow Access” only on the correct Volume: “Missing Folder Access Permissions”, “There are still some folders that require access permissions. djay may not be able to access all the files in your library.”
  2. Clicking continue: brings back the Relinking Missing Files window that is continuing its job
  3. Djay Pro has found files that are missing (51482 Files)
  4. Clicking “Apply Changes”
  5. Taking a long time, so I guess it is relinking 51482 files
  6. “The changes have been successfully applied to your library.”
  7. “Could not load track” “There was a problem accessing the file.”
  8. Tracks not loaded at all, so no cover image or title like in point 6.

Returning to today’s version of Library
23. Brings back the “show in finder” option on right click of local files
24. Track does not load
25. Track info works: waveform, cue points, bpm, key etc are shown in info window pane

Testing revoking disk permission on removable volume in privacy settings
26. “djay Pro” will have access to data on removable storage until it is quit, You can choose to quit “djay Pro” now, or do it on your own later.
27. Clicking “Quit & Reopen”
28. All tracks greyed out in Djay, but right click Show in finder still works.
Returning disk permission on removable volume in privacy settings
29. Clicking “Quit & Reopen”
30. All tracks showing cover images again
31. Still " Could not load track"
Conclusion: disk permission/privacy setting has no influence.

I guess dragging 50.000+ files from usb volume into Djay Pro collection will solve the problem :wink:

Hardware/Software setup:
Mac mini
macOS Ventura 13.5
Djay Pro 5.1.5
macOS Privacy settings>Files and Folders>Djay Pro>Removable Volumes = checked
Music collection on external 1TB Sandisk SSD (50.000+ tracks in single folder)

1 Like

There was a bug. Update to 5.1.6

via AppStore? AppStore (NL) still has 5.1.5

Think the update was only for IOS, not MacOS

yes you are right: on 19 April 2024
App Store macOS = 5.1.5
App Store iPad OS = 5.1.6

Hi @jefuqs, please use search before creating new topics. I’ve merged yours with this existing one. Please read above. The engineering team is aware of this issue and is investigating further. I’ll report back here when I have news. Thanks!