Mapping for Traktor Kontrol S4

Hey guys,
I want to buy the software DJAY for my Traktor S4, but I’m not going to do this until there is a Mapping for the S4 available. Who can give me a mapping?

Even with midi mode turned on on my S4 Djay still doesn’t recognise it’s connected. Is there something else I need to do?

I used this and it worked like a charm: https://gist.github.com/GuiSim/c8f11f…

Any update on a mapping?

We do not have a mapping for your S4. But if you need help mapping it yourself, just let us know and contact us via email: support(at)algoriddim.com

there is a mapping but it does not work everytime u launch djay sometimes it works sometimes it dont

Any progress on mapping for the S4? Its not working doing it manually. Very frustrating

Yep, i tried it a few times, until someone told me that it’s not possible. This is so silly…

Please make sure to switch the controller into Midi Mode first. Learn more:
https://www.native-instruments.com/en/support/knowledge-base/show/3659/how-to-use-your-native-instru…

Hello,
how to manually mapped traktor s4 mk2

Hi there,

have you initialised every button with the Native Instruments Controller Editor?

Cheers,Lukas E.

Hi there,

Native Instruments controllers need to get initialised with the Native Instruments Controller Editor in order to be mappable.
Use this starting guide for the S2:
http://help.algoriddim.com/customer/en/portal/articles/2344140-setting-up-the-traktor-kontrol-s2-wit…

Cheers,Lukas E.

I’ve been able to do it for the S4. Download MIDI Monitor (free application), and use that to test whether or not your computer is recognizing the controller’s MIDI signals. Once you download MIDI Monitor, make sure to check the “MIDI Sources” box. It took some restarting, unplugging, etc. to finally have the S4 be recognized, but once it was recognized by MIDI Monitor, mapping in Djay became an option. Hopefully that helps…

algoriddim djay pro kontrol s4mk2 mapping
Djay see the S4 I map all the Buttons But nothing works , It works in Djay midi window

You have to plug in the extra power brick to get it to work properly. But getting it mapped correctly is a mess.

I have managed to get most of the S4 mapped. Took a while but I have managed to get most of the knobs and buttons working good.
Biggest culprit is the lack of feedback such as LED indications and levels. DJay doesn’t see any MIDI output for the S4 buttons. The checkbox for MIDI out is greyed out in the MIDI mapping interface for all buttons.

DJay people: Is it even possible to get LED feedback? And if so how should I map the levels out to the surface?

Cheers!
Peter

Great!
Thanks Guillaume. Will try it out and let know how it goes.

Cheers!
Peter

Guillaume, I tried your setup and it worked as mine. Great but without any LED feedback. Or have managed to get the LEDs to light up?
Would be nice to see status indicators such as when looping is enabled, which quench’s is active, or the volume on each track.

Any way thanks!

Peter

Hi guys - same issue here - S4 (mk1) and trying to use DJ Pro but nothing! I’ve followed all the steps I can find over the internet to get it working with no luck. DJ Pro detects my S4 but nothing on my controller works ONLY the main sound level. Any ideas? THanks

Has this changed at all with Dj Pro 2 ?