Match not working on MacOS (Apple Music Library)

I get a weird behaviour with the match function that it suddenly stops working. I don’t know how to trigger the behaviour but it usually happens already after playing 2-3 tracks and than instead of showing suggestions for matching tracks, it says “No match results”, even though when I start the program new I get all the match results correctly for the same track.

I can change between “Active Deck” and “Custom”, i.e. drag-and-drop the track in the side panel and still no matching tracks found.

So at the moment the only way I get the match function to work properly is to close and re-open djay.

I had the same experience. Not sure how to reset it.

Hi @fizzyleclou ,

Welcome to the Community and thanks for reporting this issue with Match when using the Music/iTunes library in djay. I’ve just tried to reproduce this behavior, but haven’t been able to. For this reason, could you please get a video of the issue occurring and drop it here? Just let me know when you’ve done so, and then I can further troubleshoot this with you.

@Michael_Wisniewski - if this behavior is also happening for you, a video would really help us to better understand what exactly might be going on here.

Also, could you both share if this happens consistently, or does it seem to happen at random times? Does it happen only after a certain amount of time DJing with djay? @fizzyleclou - I know you said it happens after playing 2-3 tracks, but as stated above I wasn’t able to reproduce this.

Thanks in advance for the additional information!

Hi Emily

So I cannot recreate this problem anymore. I also don‘t know what exactly was causing this problem. If I manage to get this problem again I would make a screen recording and share it.

Thank you for your help and kind regards!

1 Like

Thanks for following up! Please do reach out again if you run into any additional problems. Otherwise, I’ll mark this bug as solved for now. Have a great day!