MIDI Mapping a NEW “Hercules Impulse 500”

Love the App BUT I am frustrated!!
I have purchased and returned several controllers because the mapping is not working!

Was not Mapped correctly out of the box and when remapping manually still not working for my newest purchase “Hercules Impulse 500” I chose from list on Algoriddim site.

I can not afford to continue this and am feeling forced to switch to SERATO PRO and a laptop and that totally sucks! Plus I have a few gigs coming up and don’t want to flake out.
Is there any way to FIX the mapping for my Impulse 500???

I have an Inpulse 500 myself and I don’t see any significant problems or even errors with the standard mapping. I have also remapped many buttons and knobs to suit my needs, but even out of the box the controller was fully usable. Only the use of the FX buttons in conjunction with the filter controller does not run as the manufacturer has thought and as it is usable, for example, with DJUCED. What exactly does not work for you or bothers you so much?

As of today play pause doesn’t work on deck 1, even if it go to mapping they all of a sudden don’t respond. I punched new from Amazon and was told I could not replace only refund cause it was a 3rd party seller.

I don’t have time or money to wait for 10 days refund or repurchase so I was hoping I could remap.

Is there a way to reset to factory? I don’t see any options in iPad version of DJ pro. I could access an old MacBook if I need to access more features. Maybe firmware or drivers in device need to be updated?

This all sounds more like a problem with the device itself. Have you tried it with the MacBook to see if the controller is recognized correctly, even with DJUCED or even Serato?
It could also be that it’s the connection to the iPad. How did you connect it? Sometimes the cables and adapters cause problems as well.
A firmware update is certainly not a bad idea, but I don’t think it’s because of that. But it would be a simple step to try in any case.

1 Like

Hey @MAGiCand_theMiC ,

Thank you for posting regarding this here in the Community.

What iOS device/version have you experienced this with? And what version of djay?

Furthermore, as @Chris_R , suggested, could you please confirm the following:

x Is the controller recognized correctly when connected to your MacBook? and if it isn’t in conjunction with djay, is it with a different app?
x What exact steps did you take to connect the controller to your iOS device (and to your MacBook) ?

We’ll be on the lookout for your reply. Cheers!