Mix recording volume is too low.

Why is the volume (amplitude) of recordings so low?

No matter if I record on my M1 MacPro, M1 12” iPad Pro , or M2 11” iPad Pro the playback of recordings is just way too low.

This can be shown in the attached image, you can see the waveform’s amplitude on Deck 2 is lower in both the track overview and also the main display.

It’s even more noticeable on a multi track beat matched mix, I’ve just recorded the one track for demonstration here.

I have to export the tracks into another program to amplify them to get them back to a ‘normal’ level before they’re fully payable elsewhere.

This has been ongoing for many versions of Djay but I’m fed of up of having to do all the extra legwork after recording a mix.

Any chance this could be addressed in a future update.


I always experienced this but it seems to be better as of Djay 5 and up for me.

You mean the levels a processed track has?

If you want to record a mix that has the same average ampitude as a processed track you need a limiter on your master channel. And you need to push it rather hard.

For the sound of the whole mix, this is much better done after its recorded.
(as you seem to do)
Most tracks are close to 0 dbfs and anything above is clipping.
if you add som low end with your eq it will be clipping
If your gain is slightly off, it will be clipping . . .

Look into gain staging to understand the whole chain of levels.

All I want though, is djay to record what is played without the program deciding to adjust the levels, especially the lowering of the amplitude.

If there is a bit of clipping, I’m not going to care when it’s played in the car.

Also, the track demonstrates that even with a single track recorded, auto gain used (so apparently no clipping) it still records at a lower level than the original track.

Even an ‘as is’ setting which overrides the program’s automated adjustments would be good.

Screenshot 2024-04-22 at 10.03.25

Output Headroom seems the only setting that could effect recording levels.

If you dont care about clipping, auto gain and audio limiter should be off.
All they do is lower a loud signal (and prevent clipping)

Or get yourselves a brick-wall limiter and add it to the output as a vst or AU plugin

Did some testing, and if you record a file without any volume changes.
You get close to the same amplitude as the source file
0,09 db lower than the original file on a pure sine wave. (.wav file)

What is a bit disturbing is that you get clipping before the red “leds” light up

@Slak_Jaw or anyone knowing the “internal circuitry”
Does this mean I have to lower the internal gain on all files to be sure not to have any clipping?
(I do not trust the internal limiters)

Have tested some more with hardware connected.
With normal gain staging, there seems no practical way of getting a distorted signal.
pheeew :sweat_smile:

Hi @sooteee, I spoke with the engineering team and this is what they had to say:

  1. It’s totally expected that recordings are quieter in djay. Most modern music is mastered to be as absolutely loud as possible, so in order to have any headroom to add FX or mix two songs together we need to turn the volume down. This is why the auto gain targets a volume that is roughly 6 dB quieter than the average mastered pop song.
  2. If you want your final mix to be as loud as a commercial release the proper way to do that is to master it in an external app.
  3. Having said that, to get the loudest recorded output from djay, you can turn off auto gain and set the Output Headroom to None. Just be careful not to push the levels too high and cause distortion.
1 Like

@spiro regarding your observations, this is what the engineering team had to say:

  1. Indeed, the channel meters are showing the red LED a little too late. This will be addressed in a future update.
  2. The limiter can be trusted to prevent clipping and audible distortion. As long as you don’t ride it hard but only occasionally touch it it’s practically inaudible.
1 Like


Perfect! That all makes sense and I can see why now.

Just turned off all the auto adjustments and tried a quick record and much more like what I’d expect! :grin:

Given that it’s only for my own use in the car, or down the gym, I’m not too bothered if the odd bit of clipping gets through……I just want to be able to make my ear drums bleed!!! :rofl:

Thanks for the responses all.



Yeah I think it’s too allow for room, so doesn’t get distorted. Engine DJ years for years have been saying the same thing but when it’s explained it like “oh yeah I get that now”

1 Like

Excellent! You’re welcome @sooteee

1 Like

2 x K2’s
MacBook Pro 22
Latest Dj pro
Evermix 4
Oyaide cables

Can anyone tell me the best settings for quality recordings with my hardware ?

Every time I record my sets they’re all different in recording quality no matter what I do. Don’t get me wrong they are listenable but not quality

I listen to other people’s stuff and I always say ‘why don’t mine sound like that ‘ !
Crisp not muddy.

I stay within the bpm/tempo range of the tracks being played as not to disrupt the key
All my tunes are AIFF format when purchased.

I have auto gain and audio limiter turned on in the software ??
The Evermix box is set as 320kps for recording as recommended by Evermix
I adjust the gains on the PX5 so the Evermix meter peaks at +6.

Is there anything else that should be set on the mixer or in the programme ?

Gimme something to try !

Hi @Daveworzel, I’ve merged your topic with this existing one as they are pretty closely related. Please refer to the discussion above.

In general, I would recommend using the limiter and/or headroom settings to ensure you don’t have distortion and clipping. Then I would run your mix through an external master app. There are lots of options out there. I’ve personally used Platinum Notes by Mixed in Key.

I have run my tunes through PN but they seem quiet and limp.
The db is set at -12 (default) as recommended by mixed in key.
I’ll change the headroom to -6 on PN and have another go.

1 Like

If I am recording re edits of tracks that I edit, I record in WAV 10.1MB/min,
If I am making a mix to upload to either You tube or Mixcloud or Soundcloud, I record in AIF 1MB/Min.
The WAV obviously sounds much better on a live system system but the AIF sounds ok in headphones/car radio

1 Like

If loudness is what you are missing compared to other mixes you hear,
you should use a compressor or limiter on your final file.

The whole area of compressors/limiter is quite a rabit hole, and used wrong, it can sound terrible. But if loudness is your problem, that is most likely a solution.
Do you know anyone doing music production you could talk to and do some testing?

Do you have a recording you want to test with?

What kind of mixes are you comparing with ? Music style and mixing style?

I would drop the evermix box and let the mixer signal be recorded directly to your computer in 24bit or 16 bit wav. That way there is one less stage of digital to analog conversion and allen & heath are known for high quality audio.
Recording straight to mp3 seems just wrong if you start with uncompressed files (.aif’s)
Listening to mp3 is not a problem, but processing a mp3 is not optimal.

Have you tried some recordings with key-lock off, to see if you like the results better?

1 Like

It’s not the loudness or anything specific.
It’s the quality. The mixes always sound muddy and not crisp. That’s what I’m looking for.

All I want to do is buy tunes, play and record them and listen to the mixes for myself and send to friends on quality hardware.

Im not a computer buff or tech nerd just a 48 yr old school raver so for me the easiest option was to buy an Evermix that I thought was for the job. Tried PN but that hasn’t worked either.

I’ve heard about Audacity and other programmes but ain’t got a clue how to use and install them. And feel it’s all too complicated for something that should be pretty straightforward. Turn the gain knob to suit the meter and away you go. Boy I was wrong.

sounds like mp3 to me hehehe
Have you tried using the recording function inside djay with .wav as your recording format?
If it still sounds muddy, did you try testing with no key-lock? just for comparison?

I feel its more the opposite for me. The “supercrispness”, especially for snares, makes me miss the noisy recorded vinyl sound . . . always something that is a bit off isnt it!

As long as you are using quality tracks ie 320mbps or wav, the recordings in the Djay app itself sound very good as long as they are recorded in WAV 10.1m/min

1 Like